summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-18 13:54:36 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-18 14:03:48 +0000
commit684103b35a168b0c28229780d651f10aed1652da (patch)
tree1d758fe6f13e9d477b9c059825c122b789925131 /sci-chemistry
parentsys-cluster/charm: Fix for new rpc situation (diff)
downloadgentoo-684103b35a168b0c28229780d651f10aed1652da.tar.gz
gentoo-684103b35a168b0c28229780d651f10aed1652da.tar.bz2
gentoo-684103b35a168b0c28229780d651f10aed1652da.zip
sci-chemistry/tinker: Version Bump
Closes: https://bugs.gentoo.org/640608 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/tinker/Manifest2
-rw-r--r--sci-chemistry/tinker/files/7.1.2-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/8.2.1-openmp.patch18
-rw-r--r--sci-chemistry/tinker/files/tinker-7.1.2-build.patch17
-rw-r--r--sci-chemistry/tinker/tinker-8.2.1.ebuild (renamed from sci-chemistry/tinker/tinker-7.1.2.ebuild)10
5 files changed, 24 insertions, 38 deletions
diff --git a/sci-chemistry/tinker/Manifest b/sci-chemistry/tinker/Manifest
index 1628482e5af4..78b83206c8b5 100644
--- a/sci-chemistry/tinker/Manifest
+++ b/sci-chemistry/tinker/Manifest
@@ -1 +1 @@
-DIST tinker-7.1.2.tar.gz 28468683 SHA256 fdee18915cff9044fd083bb2271083c221db6d05de2cb98fc111b136e23e6899 SHA512 4524259754b0f11d7e2e8997ebd85eae7d28f8dbb1edb2d9818aa0a96640de0049aa4937236694f1a11743dee187d612f775b233a73cc96c2708d620457a7dc2 WHIRLPOOL f3e29eaf67d25ae6d4f3c4e3546798e66bd626929fddd45b9d1ff9f2143cd57dcc5079226f3ceaa142f4c6a168c4a150a51be1336a5ca13384338795ef3a6d46
+DIST tinker-8.2.1.tar.gz 33015410 BLAKE2B 0b7c94662248761459cf9d681056f5cf9c4d669a790a522f23f800bf355235f6a9f392e008b13d14cf1e17d9725abb6512077c24ff7772108d69c9cf35b43e6e SHA512 5039078781d1ce226456882dd95ad15715f1e91829d26efcdb29ceedc213973883699eb6710b0a162a74208809305b7fee734b175139e6df63d0460fe5751ae7
diff --git a/sci-chemistry/tinker/files/7.1.2-openmp.patch b/sci-chemistry/tinker/files/7.1.2-openmp.patch
deleted file mode 100644
index f3e8e2932b4a..000000000000
--- a/sci-chemistry/tinker/files/7.1.2-openmp.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/source/initial.f b/source/initial.f
-index 835f228..4099c74 100644
---- a/source/initial.f
-+++ b/source/initial.f
-@@ -73,8 +73,8 @@ c
- c
- c Intel compiler extensions to OpenMP standard
- c
--!$ call kmp_set_stacksize_s (2**28)
--!$ call kmp_set_blocktime (0)
-+! call kmp_set_stacksize_s (2**28)
-+! call kmp_set_blocktime (0)
- c
- c values of machine precision constants
- c
diff --git a/sci-chemistry/tinker/files/8.2.1-openmp.patch b/sci-chemistry/tinker/files/8.2.1-openmp.patch
new file mode 100644
index 000000000000..17199f9d4cfa
--- /dev/null
+++ b/sci-chemistry/tinker/files/8.2.1-openmp.patch
@@ -0,0 +1,18 @@
+ source/initial.f | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/source/initial.f b/source/initial.f
+index ff6ed54..9769a81 100644
+--- a/initial.f
++++ b/initial.f
+@@ -85,8 +85,8 @@ c
+ c Intel compiler extensions to OpenMP standard, 268435456 bytes is
+ c 2**28 bytes, or 256 MB; comment these lines for other compilers
+ c
+-c!$ call kmp_set_stacksize_s (268435456)
+-c!$ call kmp_set_blocktime (0)
++!$ call kmp_set_stacksize_s (268435456)
++!$ call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
deleted file mode 100644
index d6ef484b19a4..000000000000
--- a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
+++ /dev/null
@@ -1,17 +0,0 @@
- make/Makefile | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/make/Makefile b/make/Makefile
-index 61d5037..9be384a 100644
---- a/make/Makefile
-+++ b/make/Makefile
-@@ -719,8 +719,7 @@ EXEFILES = alchemy.x \
- %.x: %.o libtinker.a
- ${F77} ${LINKFLAGS} -o $@ $^ ${LIBS}; strip $@
-
--all:
-- ${EXEFILES}
-+all: ${EXEFILES}
-
- install:
- rename
diff --git a/sci-chemistry/tinker/tinker-7.1.2.ebuild b/sci-chemistry/tinker/tinker-8.2.1.ebuild
index 46a8d2feb0f2..5dfafe90e1f4 100644
--- a/sci-chemistry/tinker/tinker-7.1.2.ebuild
+++ b/sci-chemistry/tinker/tinker-8.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic fortran-2 java-pkg-opt-2 toolchain-funcs
@@ -35,9 +35,9 @@ pkg_setup() {
}
src_prepare() {
- sed 's:strip:true:g' -i ../make/Makefile
- [[ $(tc-getFC) =~ "ifort" ]] || epatch "${FILESDIR}"/${PV}-openmp.patch
- cd .. && epatch "${FILESDIR}"/${P}-build.patch
+ sed 's:strip:true:g' -i ../make/Makefile || die
+ [[ $(tc-getFC) =~ "ifort" ]] && eapply "${FILESDIR}"/${PV}-openmp.patch
+ default
}
src_compile() {
@@ -75,7 +75,7 @@ src_compile() {
emake \
-f ../make/Makefile \
BINDIR="${S}"/../bin \
- rename
+ rename_bin
}
src_test() {