summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-11-21 16:40:02 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-11-21 19:26:27 -0700
commitbf152faadabd64cc4ccf97fddd8a197f1dbf949d (patch)
tree970bb3833f5ed38997242454ebb22f88f19bf8eb /sci-chemistry
parentsci-chemistry/votca-csgapps: version bump (diff)
downloadgentoo-bf152faadabd64cc4ccf97fddd8a197f1dbf949d.tar.gz
gentoo-bf152faadabd64cc4ccf97fddd8a197f1dbf949d.tar.bz2
gentoo-bf152faadabd64cc4ccf97fddd8a197f1dbf949d.zip
sci-chemistry/votca-ctp: Version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca-ctp/Manifest2
-rw-r--r--sci-chemistry/votca-ctp/votca-ctp-1.5.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-chemistry/votca-ctp/Manifest b/sci-chemistry/votca-ctp/Manifest
index f527423449b0..9c5c7ef28f0f 100644
--- a/sci-chemistry/votca-ctp/Manifest
+++ b/sci-chemistry/votca-ctp/Manifest
@@ -1,2 +1,4 @@
+DIST votca-ctp-1.5.1.tar.gz 1345994 BLAKE2B 6e927c5d57abfff335412bdac085c9dd81696503310e58a89bf2207b07f9d9900d11d20176a11fbde6d6cdfa97f50faa5e877889e35201ad9ed5dd93dbc158cb SHA512 686d7193cdd6a763197dd4f332554c9c6c2022c539191d0a243e70450aa2a4c7048fff3c06636aee09525516fb3717fe49934d5daf2dfcdcbc08be416cc4b6c0
DIST votca-ctp-1.5.tar.gz 1345419 BLAKE2B 148846b9118cabfa541eb4fe0129e366d0c447e2daf969833beb5df91ca7b43f0262c5845303ccf05ed8d3f9e2c2a5e0f876ec97c2601419ed04a28d56640494 SHA512 bc4dbddcefb473015a6513f44f4fddd5995a8598f82505e81b3c50ae771e64e8c979f39a347ab2deb55054e7efffad28b5ff3f73d2c1b8905bcaf6f007ff2959
+DIST votca-ctp-manual-1.5.1.pdf 948647 BLAKE2B 4afec48d0e6bb29dc86d4d22fce74a8d2197d6b7a1ed35a5b09af84c5bbc0fc49b91e045c85e5b5ab79beb5a7de1db78a15e395a1a5faf4c11cc1b58c1ffca97 SHA512 b4ae79b2da0037cc325fdff3b0fd8d142d6bfdad5bc11991cee314f40f105bcdcb1189d17679a84eb37da7a9bb686d0c5ee57c7796a0c6b787b70d53222dbc17
DIST votca-ctp-manual-1.5.pdf 970539 BLAKE2B 8646215a4c2cd7be6d4c03820f00b8067e15c27f51fb6678540026cff1af0e28dffa528423ad47a4047a8f84fc1078d503a56a4a235e004735f0276ec1a6a33e SHA512 a315c1b4b37461f4f0d30ead1fec2ca33ff23d81c9d5e4d888ef7d7dd722f68f9596826f828f8a76841d6dde6889f623b73d9fe0f8a6c5a7cec1c16a83cf9030
diff --git a/sci-chemistry/votca-ctp/votca-ctp-1.5.1.ebuild b/sci-chemistry/votca-ctp/votca-ctp-1.5.1.ebuild
new file mode 100644
index 000000000000..892997f7af3e
--- /dev/null
+++ b/sci-chemistry/votca-ctp/votca-ctp-1.5.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib
+
+IUSE="doc"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}/releases/download/v${PV}/${PN}-manual-${PV}.pdf )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca charge transport module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ ~sci-libs/votca-tools-${PV}[sqlite]
+ >=dev-cpp/eigen-3.3
+ sci-libs/gsl
+ ~sci-chemistry/votca-csg-${PV}"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [ "${PV}" != "9999" ]; then
+ DEPEND="${DEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ dev-tex/pgf
+ )"
+fi
+
+DOCS=( README.md NOTICE CHANGELOG.md )
+
+src_configure() {
+ [[ ${PV} = *9999* ]] && mycmakeargs=(
+ -DBUILD_XTP_MANUAL=$(usex doc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ [[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
+ dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-CTP, J. Chem. Theo. Comp. 7, 3335-3345 (2011)"
+ einfo "https://dx.doi.org/10.1021/ct200388s"
+ einfo
+}