summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-18 11:14:13 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-18 11:14:13 +0100
commitd4e3550d0dca9459d72d6b96c7246447227fa8cd (patch)
tree46cfabfecbb4acd98231d0ad6539a0d0a2d925fc /sci-chemistry
parentsci-chemistry/avogadro2: Remove old (diff)
downloadgentoo-d4e3550d0dca9459d72d6b96c7246447227fa8cd.tar.gz
gentoo-d4e3550d0dca9459d72d6b96c7246447227fa8cd.tar.bz2
gentoo-d4e3550d0dca9459d72d6b96c7246447227fa8cd.zip
sci-chemistry/openbabel: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.4.1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.4.1.ebuild b/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
deleted file mode 100644
index 6f60a5ab1354..000000000000
--- a/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="3.0"
-
-inherit cmake-utils optfeature toolchain-funcs wxwidgets
-
-DESCRIPTION="Interconverts file formats used in molecular modeling"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
-
-# See src/CMakeLists.txt for LIBRARY_VERSION
-SLOT="0/5.0.0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc openmp test wxwidgets"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-cpp/eigen:3
- dev-libs/libxml2:2
- sci-libs/inchi
- sys-libs/zlib
- wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.8
- doc? ( app-doc/doxygen )"
-
-DOCS=( AUTHORS NEWS.md README.md THANKS doc/dioxin.{inc,mol2} doc/README.{dioxin.pov,povray} )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.3.2-gcc-6_and_7-backport.patch
- "${FILESDIR}"/${P}-gcc-8.patch
- )
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
-}
-
-src_prepare() {
- sed \
- -e '/__GNUC__/s:== 4:>= 4:g' \
- -i include/openbabel/shared_ptr.h || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- use wxwidgets && need-wxwidgets unicode
- local mycmakeargs=(
- -DOPENBABEL_USE_SYSTEM_INCHI=ON
- -DOPENMP=$(usex openmp)
- -DBUILD_GUI=$(usex wxwidgets)
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- docinto html
- dodoc doc/{*.html,*.png}
- if use doc ; then
- docinto html/API
- dodoc -r doc/API/html/*
- fi
-
- cmake-utils_src_install
-}
-
-src_test() {
- local mycmakeargs=(
- -DOPENBABEL_USE_SYSTEM_INCHI=ON
- -DPYTHON_EXECUTABLE=false
- -DOPENMP=$(usex openmp)
- -DBUILD_GUI=$(usex wxwidgets)
- -DTESTS=$(usex test)
- )
-
- cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test -E py
-}
-
-pkg_postinst() {
- optfeature "perl support" sci-chemistry/openbabel-perl
- optfeature "python support" sci-chemistry/openbabel-python
-}