summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 22:36:04 +0000
committerSam James <sam@gentoo.org>2022-02-27 22:36:04 +0000
commitdf50910c5761df0de027da735f6990e577f2ead7 (patch)
tree909a14a6dc1bf96f77cf9e6bf6dc1ff21a39ddbb /sci-chemistry
parentprofiles: fix sys-libs/tapi mask/last-rites (diff)
downloadgentoo-df50910c5761df0de027da735f6990e577f2ead7.tar.gz
gentoo-df50910c5761df0de027da735f6990e577f2ead7.tar.bz2
gentoo-df50910c5761df0de027da735f6990e577f2ead7.zip
sci-chemistry/pdbcat: port to EAPI 8
Closes: https://bugs.gentoo.org/834304 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild (renamed from sci-chemistry/pdbcat/pdbcat-1.3.ebuild)15
1 files changed, 9 insertions, 6 deletions
diff --git a/sci-chemistry/pdbcat/pdbcat-1.3.ebuild b/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild
index ccdbd9928160..270e7b98fb36 100644
--- a/sci-chemistry/pdbcat/pdbcat-1.3.ebuild
+++ b/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Manipulate and process PDB files using tools such as Perl, awk, etc"
HOMEPAGE="http://www.ks.uiuc.edu/Development/MDTools/pdbcat/"
@@ -12,12 +12,15 @@ SRC_URI="http://www.ks.uiuc.edu/Development/MDTools/${PN}/files/${P}.tar.gz"
LICENSE="free-noncomm"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${P}-gcc.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc.patch
+)
+
DOCS=( README )
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+
+ cmake_src_prepare
}