summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-24 18:32:12 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-24 18:33:08 +0300
commit78a8fc1ae1230167345e29479940f512b560e154 (patch)
tree381db85d9f093794fc24042a9709bc3c2ad08092 /sci-electronics/fasthenry
parentx11-wm/xpra: Add missing dependency (diff)
downloadgentoo-78a8fc1ae1230167345e29479940f512b560e154.tar.gz
gentoo-78a8fc1ae1230167345e29479940f512b560e154.tar.bz2
gentoo-78a8fc1ae1230167345e29479940f512b560e154.zip
sci-electronics/fasthenry: Fix LDFLAGS
Closes: https://bugs.gentoo.org/750134 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/fasthenry')
-rw-r--r--sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild1
-rw-r--r--sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ldflags.patch40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
index 5e4970bb32f9..b8691f8986a6 100644
--- a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
+++ b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
@@ -22,6 +22,7 @@ S=${WORKDIR}/fasthenry-3.0wr
PATCHES=(
"${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-ldflags.patch"
)
src_compile() {
diff --git a/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ldflags.patch b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ldflags.patch
new file mode 100644
index 000000000000..198f2f7e74fe
--- /dev/null
+++ b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-ldflags.patch
@@ -0,0 +1,40 @@
+diff -ruN fasthenry-3.0wr.orig/src/fasthenry/Makefile fasthenry-3.0wr/src/fasthenry/Makefile
+--- fasthenry-3.0wr.orig/src/fasthenry/Makefile 2020-07-12 19:17:05.000000000 +0300
++++ fasthenry-3.0wr/src/fasthenry/Makefile 2020-10-24 18:27:20.624660092 +0300
+@@ -49,7 +49,7 @@
+ @if [ $(SOLVER) = SPARSE_SOLVER ]; then \
+ cd ../sparse; make CC=$(CC); \
+ fi
+- $(CC) -o fasthenry $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SOLVERLIB) -lm
++ $(CC) -o fasthenry $(LDFLAGS) $(CFLAGS) $(OBJS) $(MOBJS) $(NONUNIOBJS) $(SOLVERLIB) -lm
+ mv fasthenry $(BIN)/fasthenry
+
+ clean:
+diff -ruN fasthenry-3.0wr.orig/src/misc/Makefile fasthenry-3.0wr/src/misc/Makefile
+--- fasthenry-3.0wr.orig/src/misc/Makefile 2019-03-21 23:10:58.000000000 +0200
++++ fasthenry-3.0wr/src/misc/Makefile 2020-10-24 18:28:12.805126140 +0300
+@@ -1,10 +1,10 @@
+ all: MakeLcircuit ReadOutput
+
+ MakeLcircuit: MakeLcircuit.c
+- $(CC) -O -o MakeLcircuit MakeLcircuit.c -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) -o MakeLcircuit MakeLcircuit.c -lm
+
+ ReadOutput: ReadOutput.c
+- $(CC) -O -o ReadOutput ReadOutput.c -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ReadOutput ReadOutput.c -lm
+
+ clean::
+ -@rm -f *.o MakeLcircuit ReadOutput
+diff -ruN fasthenry-3.0wr.orig/src/zbuf/Makefile fasthenry-3.0wr/src/zbuf/Makefile
+--- fasthenry-3.0wr.orig/src/zbuf/Makefile 2019-09-08 22:53:50.000000000 +0300
++++ fasthenry-3.0wr/src/zbuf/Makefile 2020-10-24 18:29:50.686000362 +0300
+@@ -41,7 +41,7 @@
+ LIBS = -lm
+
+ zbuf: $(OBJS)
+- $(CC) -o zbuf $(CFLAGS) $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o zbuf $(CFLAGS) $(OBJS) $(LIBS)
+ mv zbuf $(BIN)/zbuf
+
+ clean: