summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-18 23:05:12 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-18 23:05:43 +0300
commitfc4ee19d281cd3ecd973f03ecccd3e25603f1c89 (patch)
treeb59d5d2295207343393bd59054a645d619c9a937 /sci-electronics/fasthenry
parentdev-util/gprof2dot: Fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.tar.gz
gentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.tar.bz2
gentoo-fc4ee19d281cd3ecd973f03ecccd3e25603f1c89.zip
sci-electronics/fasthenry: Version bump
Closes: https://bugs.gentoo.org/723632 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/fasthenry')
-rw-r--r--sci-electronics/fasthenry/Manifest1
-rw-r--r--sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild37
-rw-r--r--sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-cflags.patch48
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-electronics/fasthenry/Manifest b/sci-electronics/fasthenry/Manifest
index 1674dfd6b72b..93ff7b621b6b 100644
--- a/sci-electronics/fasthenry/Manifest
+++ b/sci-electronics/fasthenry/Manifest
@@ -1 +1,2 @@
+DIST fasthenry-3.0wr-071720.tar.gz 5196905 BLAKE2B 577e1b6c9b5483144f54de96439a2f11d41bfe54fbd9973084c2e17d180843ceaaa946899ae1bc71ef7dcf3b048da9775f2015fe03ce01ece67f66f998adba9b SHA512 90419c9e8cbdbb16dcb34db65e4e87643cbdbfad980012ea8c08d4fc062a113e388a38705d4d5af3970107ff71630fe7afe3b29e1de731c147798e683ec71cd3
DIST fasthenry-3.0wr-082514.tar.gz 3738940 BLAKE2B 3fd5d45e047725bf04299bf77f7385f42faa68d234a06f57cc494684a65e1c02d3879cb42a02dc3f53b0a63b5f5caf5d0a24ae1182ef19695e37a758b9bdb5e1 SHA512 53764d2eb5577d89934ad882af0eeadc6196d95a9c22cd6648e0c342c33ef1d8289b3b6c9ef48662ae4611e2bf914e4c4a68ddc536dc7921e0296cd59c5f3538
diff --git a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
new file mode 100644
index 000000000000..5e4970bb32f9
--- /dev/null
+++ b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Three dimensional inductance computation program, Whiteley Research version"
+HOMEPAGE="http://www.wrcad.com/freestuff.html"
+SRC_URI="http://www.wrcad.com/ftp/pub/fasthenry-$(ver_cut 1-2)wr-$(ver_cut 4)$(ver_cut 5)$(ver_cut 3).tar.gz"
+
+LICENSE="all-rights-reserved"
+RESTRICT="mirror bindist"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/fasthenry-3.0wr
+
+PATCHES=(
+ "${FILESDIR}/${P}-cflags.patch"
+)
+
+src_compile() {
+ tc-export CC
+ emake all
+}
+
+src_install() {
+ dobin bin/fasthenry
+ dobin bin/zbuf
+ dodoc -r doc/*
+ dodoc -r examples
+}
diff --git a/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-cflags.patch b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-cflags.patch
new file mode 100644
index 000000000000..7053406cb26f
--- /dev/null
+++ b/sci-electronics/fasthenry/files/fasthenry-3.0.20.07.17-cflags.patch
@@ -0,0 +1,48 @@
+diff -ruN fasthenry-3.0wr.orig/src/fasthenry/mk_syscfg.inc fasthenry-3.0wr/src/fasthenry/mk_syscfg.inc
+--- fasthenry-3.0wr.orig/src/fasthenry/mk_syscfg.inc 2020-07-23 01:18:06.000000000 +0300
++++ fasthenry-3.0wr/src/fasthenry/mk_syscfg.inc 2020-10-18 23:01:19.019207947 +0300
+@@ -2,7 +2,7 @@
+ # except for MinGW.
+
+ #CFLAGS = -O -g -DFOUR
+-CFLAGS = -O3 -DFOUR
++CFLAGS += -DFOUR
+
+ # For MinGW, there is no getrusage, and we'll skip a gethostname call
+ # to avoid having to link with winsock.
+@@ -12,4 +12,4 @@
+
+ # We're going to assume gcc, you'll need to comment this if a
+ # non-compatible compiler is used.
+-CC := gcc
++#CC := gcc
+diff -ruN fasthenry-3.0wr.orig/src/sparse/Makefile fasthenry-3.0wr/src/sparse/Makefile
+--- fasthenry-3.0wr.orig/src/sparse/Makefile 2019-09-02 21:41:53.000000000 +0300
++++ fasthenry-3.0wr/src/sparse/Makefile 2020-10-18 23:01:49.339387549 +0300
+@@ -4,7 +4,7 @@
+ # UC Berkeley
+ #
+ #CFLAGS = -O -g
+-CFLAGS = -O3
++#CFLAGS = -O3
+ LINTFLAGS = -lc -lm
+ SHELL = /bin/sh
+ #CC = cc
+diff -ruN fasthenry-3.0wr.orig/src/zbuf/mk_syscfg.inc fasthenry-3.0wr/src/zbuf/mk_syscfg.inc
+--- fasthenry-3.0wr.orig/src/zbuf/mk_syscfg.inc 2020-07-23 01:18:23.000000000 +0300
++++ fasthenry-3.0wr/src/zbuf/mk_syscfg.inc 2020-10-18 23:01:19.019207947 +0300
+@@ -2,7 +2,7 @@
+ # except for MinGW.
+
+ #CFLAGS = -O -g -DFOUR
+-CFLAGS = -O3 -DFOUR
++CFLAGS += -DFOUR
+
+ # For MinGW, there is no getrusage, and we'll skip a gethostname call
+ # to avoid having to link with winsock.
+@@ -12,4 +12,4 @@
+
+ # We're going to assume gcc, you'll need to comment this if a
+ # non-compatible compiler is used.
+-CC := gcc
++#CC := gcc