summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-26 19:52:19 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-26 19:52:19 +0100
commit8601fc63efe7f29b96fa6ce9545e994f6f1eba36 (patch)
treec0483fd25b5e0fbf2f133e3f0b7f9fbc593b2ed9 /sci-electronics/gerbv
parentdev-lua/lutok: update copyright start year (diff)
downloadgentoo-8601fc63efe7f29b96fa6ce9545e994f6f1eba36.tar.gz
gentoo-8601fc63efe7f29b96fa6ce9545e994f6f1eba36.tar.bz2
gentoo-8601fc63efe7f29b96fa6ce9545e994f6f1eba36.zip
sci-electronics/gerbv: Bump to 2.7.0
Bug: https://bugs.gentoo.org/686716 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-electronics/gerbv')
-rw-r--r--sci-electronics/gerbv/Manifest1
-rw-r--r--sci-electronics/gerbv/files/gerbv-2.7.0-fno-common-gcc10.patch28
-rw-r--r--sci-electronics/gerbv/gerbv-2.7.0.ebuild51
3 files changed, 80 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/Manifest b/sci-electronics/gerbv/Manifest
index 60900726fe67..9187fe081496 100644
--- a/sci-electronics/gerbv/Manifest
+++ b/sci-electronics/gerbv/Manifest
@@ -1,2 +1,3 @@
DIST gerbv-2.6.0.tar.gz 2346299 BLAKE2B 2b7a4293289e460f5b06f802d9ad779021a519d6ec702ea4b27df1e6a06d6779ae41fbd9aae6f0c83f9ea61fc9369dbc6aaa8d29326a9d5d139ab89a40f050f0 SHA512 a2d7601b44c8ed16a89d18713f451c0298bee65e2ea76b87e3d9d573af63d3b57758cb7cfcfb2177a22aecc7d9fdaaca3d369ea051446651af4dc542065a4377
DIST gerbv-2.6.1.tar.gz 4432481 BLAKE2B 022214846077a4fea56848fbc63096857a8a782b3469c2293567e4927b904cf59a36d5d2b2adc0be7bc395a17c615af58a231f68a8f1dbedcb77cafc55ceb849 SHA512 cbf4ce4fd2b401d65ffc6bb5a7f9da0e6fa31cb3f754ea12092c86f197c72c833805eb395562b286f6d03c2eb38e363b649f8aa1040a6207baf975fa15e48b29
+DIST gerbv-2.7.0.tar.gz 5691407 BLAKE2B 458440dd69f20fee18ce09953c7403d783b2b7df1bf977e192b1ac877ebd9ed535ef7712417e112cff82d95e1c3752ae1dd4d88dfe14dea45df7c959337cb6ff SHA512 a940de027a9cdfdc513b0740cb402d312ae33bb7f002f80ee5f3e800aa5d01b86ff277538d8a19a309d852e248b2c8136645ede2d5d33456e5bfb49336c1256e
diff --git a/sci-electronics/gerbv/files/gerbv-2.7.0-fno-common-gcc10.patch b/sci-electronics/gerbv/files/gerbv-2.7.0-fno-common-gcc10.patch
new file mode 100644
index 000000000000..74879d46b06e
--- /dev/null
+++ b/sci-electronics/gerbv/files/gerbv-2.7.0-fno-common-gcc10.patch
@@ -0,0 +1,28 @@
+--- a/src/callbacks.h
++++ b/src/callbacks.h
+@@ -26,7 +26,7 @@
+ \ingroup gerbv
+ */
+
+-enum {
++enum CALLBACKS_SAVE_FILE_TYPE {
+ CALLBACKS_SAVE_PROJECT_AS,
+ CALLBACKS_SAVE_FILE_PS,
+ CALLBACKS_SAVE_FILE_PDF,
+@@ -41,13 +41,13 @@
+ CALLBACKS_SAVE_LAYER_AS,
+ CALLBACKS_SAVE_FILE_IDRILL
+
+-} CALLBACKS_SAVE_FILE_TYPE;
++};
+
+-enum {
++enum toggle_layer {
+ LAYER_SELECTED = -1,
+ LAYER_ALL_ON = -2,
+ LAYER_ALL_OFF = -3,
+-} toggle_layer;
++};
+
+ void
+ callbacks_new_project_activate (GtkMenuItem *menuitem,
diff --git a/sci-electronics/gerbv/gerbv-2.7.0.ebuild b/sci-electronics/gerbv/gerbv-2.7.0.ebuild
new file mode 100644
index 000000000000..48379be86259
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
+HOMEPAGE="http://gerbv.geda-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples unit-mm"
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/cairo"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.7.0-fno-common-gcc10.patch )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-update-desktop-database \
+ $(use_enable unit-mm)
+}
+
+src_install() {
+ rm README-{git,release,win32}.txt || die
+ default
+ dodoc CONTRIBUTORS HACKING
+
+ rm doc/Doxyfile.nopreprocessing || die
+ if use doc; then
+ find doc -name 'Makefile*' -delete || die
+ dodoc -r doc/.
+ fi
+
+ if use examples; then
+ find example -name 'Makefile*' -delete || die
+ dodoc -r example/.
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}