summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-14 23:30:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-15 00:20:51 +0200
commit5102f2f821518f54a760f908d7b7abb522c81eb6 (patch)
treebbf055e7d8c8921e8b3fa9a6f1b2f5c26cf4432a /sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild
parentdev-cpp/cpp-httplib: drop old 0.14.1-r1 (diff)
downloadgentoo-5102f2f821518f54a760f908d7b7abb522c81eb6.tar.gz
gentoo-5102f2f821518f54a760f908d7b7abb522c81eb6.tar.bz2
gentoo-5102f2f821518f54a760f908d7b7abb522c81eb6.zip
sci-electronics/ghdl: drop old 4.0.0_pre20231218-r1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild')
-rw-r--r--sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild b/sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild
deleted file mode 100644
index 423768c69164..000000000000
--- a/sci-electronics/ghdl/ghdl-4.0.0_pre20231218-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ "${PV}" = *_pre20231218 ]] && COMMIT=2135cbf1458bd1b8b8f42bda81222ab57bd66de6
-
-ADA_COMPAT=( gnat_2021 gcc_13 )
-LLVM_MAX_SLOT=17 # Check "configure" script for supported LLVM versions.
-
-inherit ada edo llvm toolchain-funcs
-
-DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
-HOMEPAGE="https://ghdl.github.io/ghdl/
- https://github.com/ghdl/ghdl/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
-else
- SRC_URI="https://github.com/ghdl/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${COMMIT}"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="llvm"
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-RDEPEND="
- ${ADA_DEPS}
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-util/patchelf
-"
-
-PATCHES=( "${FILESDIR}/${PN}-4.0.0_pre20231218-no-pyunit.patch" )
-
-pkg_setup() {
- ada_pkg_setup
-
- use llvm && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
-}
-
-src_configure() {
- tc-export CC CXX
-
- local -a myconf=(
- --disable-werror
-
- --libdir=$(get_libdir)
- --prefix=/usr
-
- --enable-libghdl
- --enable-synth
- )
-
- if use llvm ; then
- myconf+=( --with-llvm-config=llvm-config )
- fi
-
- # Not a autotools script!
- edo sh ./configure "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- patchelf --set-soname libghw.so lib/libghw.so || die
-}