summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:05:05 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:05:15 +0100
commitb9dfc299925659f3a2d124f6c9c89a1755b10e29 (patch)
treef62b7f44ae652895332dc7d24175f0ee23e4cf45 /sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
parentgames-simulation/simutrans: Fix language pack URL (diff)
downloadgentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.tar.gz
gentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.tar.bz2
gentoo-b9dfc299925659f3a2d124f6c9c89a1755b10e29.zip
sci-electronics/gspiceui: add version 1.2.87, bump to wxwidgets gtk3
Closes: https://bugs.gentoo.org/769629 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-electronics/gspiceui/gspiceui-1.2.87.ebuild')
-rw-r--r--sci-electronics/gspiceui/gspiceui-1.2.87.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild b/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
new file mode 100644
index 000000000000..8c007ed14442
--- /dev/null
+++ b/sci-electronics/gspiceui/gspiceui-1.2.87.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit desktop optfeature toolchain-funcs wxwidgets
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="GUI frontend for Ngspice and Gnucap"
+HOMEPAGE="https://sourceforge.net/projects/gspiceui/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ sci-electronics/electronics-menu
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ sci-electronics/ngspice
+ sci-electronics/gnucap
+ )
+"
+
+PATCHES=(
+ # Use Gentoo LDFLAGS and CXXFLAGS
+ "${FILESDIR}"/${P}-respect-users-flags.patch
+)
+
+src_prepare() {
+ default
+
+ # Adjusting the doc path at src/main/FrmHtmlVwr.cpp
+ sed -i -e \
+ "s:/share/gspiceui/html/User-Manual.html:/share/doc/${PF}/html/User-Manual.html:g" \
+ src/main/FrmHtmlVwr.cpp || die
+}
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin bin/gspiceui
+
+ einstalldocs
+ dodoc html/*.html html/*.jpg html/*.png
+ dodoc ChangeLog ReadMe ToDo release-notes-v${PV}.txt
+ doman gspiceui.1
+
+ # installing examples and according model and symbol files
+ use examples && dodoc -r lib sch
+
+ newicon -s 32 src/icons/gspiceui-32x32.xpm gspiceui.xpm
+ newicon -s 48 src/icons/gspiceui-48x48.xpm gspiceui.xpm
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
+}
+
+pkg_postinst() {
+ if use examples ; then
+ elog "If you want to use the examples, copy and extract from"
+ elog "${EROOT}/usr/share/doc/${PF} the sch and lib directory"
+ elog "side by side to your home directory to be able"
+ elog "to generate the netlists as normal user."
+ fi
+ optfeature "schematics editing" sci-electronics/geda
+ optfeature "waveform display" sci-electronics/gwave
+}