summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-13 21:50:20 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-13 21:50:20 +0100
commitd58a7efc869b096ecea8dded91644484697b0f25 (patch)
tree3aa29b715cdf7421157900862e030fca1c76bb92 /sci-electronics/klayout/klayout-0.24.9.ebuild
parentsci-libs/armadillo: Version bump (diff)
downloadgentoo-d58a7efc869b096ecea8dded91644484697b0f25.tar.gz
gentoo-d58a7efc869b096ecea8dded91644484697b0f25.tar.bz2
gentoo-d58a7efc869b096ecea8dded91644484697b0f25.zip
sci-electronics/klayout: Version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'sci-electronics/klayout/klayout-0.24.9.ebuild')
-rw-r--r--sci-electronics/klayout/klayout-0.24.9.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sci-electronics/klayout/klayout-0.24.9.ebuild b/sci-electronics/klayout/klayout-0.24.9.ebuild
new file mode 100644
index 000000000000..76265f4e2fdf
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.24.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=no
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://www.klayout.org/downloads/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/designer:4
+ dev-qt/qtgui:4[qt3support]
+ sys-libs/zlib
+ $(ruby_implementations_depend)
+"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.23.10-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -ruby ${RUBY} \
+ -qtbin /usr/lib64/qt4/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install
+
+ cd ..
+ dobin bin/klayout
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot
+
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby
+}