summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-04-19 17:30:48 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-04-19 17:33:20 +0300
commitcf18b1de40c136c26cd7923e49df5c4b2a9c511b (patch)
treedad4fabe3bf5750f94b3e8ece8cc0d1c93f557be /sci-electronics/klayout/klayout-9999.ebuild
parenttexlive-module.eclass: Make SRC_URI more configurable (diff)
downloadgentoo-cf18b1de40c136c26cd7923e49df5c4b2a9c511b.tar.gz
gentoo-cf18b1de40c136c26cd7923e49df5c4b2a9c511b.tar.bz2
gentoo-cf18b1de40c136c26cd7923e49df5c4b2a9c511b.zip
sci-electronics/klayout: Version bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/klayout/klayout-9999.ebuild')
-rw-r--r--sci-electronics/klayout/klayout-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sci-electronics/klayout/klayout-9999.ebuild b/sci-electronics/klayout/klayout-9999.ebuild
index 127d36ffb70f..e98e242fe19b 100644
--- a/sci-electronics/klayout/klayout-9999.ebuild
+++ b/sci-electronics/klayout/klayout-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RUBY_OPTIONAL=no
USE_RUBY="ruby25"
# note: define maximally ONE implementation here
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit toolchain-funcs python-single-r1 ruby-ng
@@ -78,7 +78,13 @@ each_ruby_install() {
cd "${T}/bin" || die
dodir "/usr/$(get_libdir)/klayout"
- mv lib* "${ED}/usr/$(get_libdir)/klayout/" || die
+ mv lib* lay_plugins db_plugins "${ED}/usr/$(get_libdir)/klayout/" || die
+
+ dodir "$(python_get_sitedir)"
+ mv pymod/* "${ED}/$(python_get_sitedir)/" || die
+ rmdir pymod || die
dobin *
+
+ python_optimize
}