summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <andreas.huettel@ur.de>2021-11-09 15:07:33 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-09 15:13:17 +0100
commit7fb9f3b63f231aa3c6ad67fbbbb71f8d967a6d73 (patch)
treede9a07dbf5bb6fb11a95c579ffd5d44351d8e71e /sci-electronics/labone
parentdev-python/pep517: New pkg, v0.12.0 (diff)
downloadgentoo-7fb9f3b63f231aa3c6ad67fbbbb71f8d967a6d73.tar.gz
gentoo-7fb9f3b63f231aa3c6ad67fbbbb71f8d967a6d73.tar.bz2
gentoo-7fb9f3b63f231aa3c6ad67fbbbb71f8d967a6d73.zip
sci-electronics/labone: Version bump 21.08
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-electronics/labone')
-rw-r--r--sci-electronics/labone/Manifest1
-rwxr-xr-xsci-electronics/labone/files/hf2-data-server11
-rw-r--r--sci-electronics/labone/files/hf2-data-server.conf2
-rwxr-xr-xsci-electronics/labone/files/labone-data-server11
-rw-r--r--sci-electronics/labone/files/labone-data-server.conf2
-rw-r--r--sci-electronics/labone/labone-21.08.20515.ebuild83
6 files changed, 110 insertions, 0 deletions
diff --git a/sci-electronics/labone/Manifest b/sci-electronics/labone/Manifest
index 518c5f95a137..fa395e14a4f0 100644
--- a/sci-electronics/labone/Manifest
+++ b/sci-electronics/labone/Manifest
@@ -1 +1,2 @@
DIST LabOneLinux64-16.12.42529.tar.gz 120562203 BLAKE2B 5d5e3816ad47e79b8b029b318f76b72908949fb4f92b5497d4b03abf5562144951d2a95832cdd2112df8922a9ea002a508f0d81c5f1fee3a017540dceb70233a SHA512 31068792ca4c2ab88490eacf35a84f8a2c31b330087ee91154e5ecdae63bcf557563c80e45af4a855df9d7d9a1d5b5a761ef5d957ce357368706307ea5ea196b
+DIST LabOneLinux64-21.08.20515.tar.gz 399058267 BLAKE2B 624c4dc4a01edb69f9b36a435744d10b3638c91c7ac0c1e9765cf913e605fe32d1935fa131d650f38a5b713df916d92b985ac5f6489b031bba9b6ec8a1370d4a SHA512 f229a885ea91cc518c4819ad76a928829eb1699603ba48fb745d4a99faca116b100831c17a48243922912c68de27b7938387677ffa2e996a122f36c33d0a205c
diff --git a/sci-electronics/labone/files/hf2-data-server b/sci-electronics/labone/files/hf2-data-server
new file mode 100755
index 000000000000..c9bc2807afcf
--- /dev/null
+++ b/sci-electronics/labone/files/hf2-data-server
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/run/hf2-data-server.pid"
+command="/opt/bin/ziServer"
+command_args=""
+
+depend() {
+ need network
+}
diff --git a/sci-electronics/labone/files/hf2-data-server.conf b/sci-electronics/labone/files/hf2-data-server.conf
new file mode 100644
index 000000000000..3f9caccc0709
--- /dev/null
+++ b/sci-electronics/labone/files/hf2-data-server.conf
@@ -0,0 +1,2 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
diff --git a/sci-electronics/labone/files/labone-data-server b/sci-electronics/labone/files/labone-data-server
new file mode 100755
index 000000000000..cf56478deb19
--- /dev/null
+++ b/sci-electronics/labone/files/labone-data-server
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/run/labone-data-server.pid"
+command="/opt/bin/ziDataServer"
+command_args=""
+
+depend() {
+ need network
+}
diff --git a/sci-electronics/labone/files/labone-data-server.conf b/sci-electronics/labone/files/labone-data-server.conf
new file mode 100644
index 000000000000..3f9caccc0709
--- /dev/null
+++ b/sci-electronics/labone/files/labone-data-server.conf
@@ -0,0 +1,2 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
diff --git a/sci-electronics/labone/labone-21.08.20515.ebuild b/sci-electronics/labone/labone-21.08.20515.ebuild
new file mode 100644
index 000000000000..59b710589333
--- /dev/null
+++ b/sci-electronics/labone/labone-21.08.20515.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg desktop systemd udev
+
+DESCRIPTION="Platform independent instrument control for Zurich Instruments devices"
+HOMEPAGE="https://www.zhinst.com/labone"
+SRC_URI="https://www.zhinst.com/sites/default/files/media/release_file/2021-09/LabOneLinux64-${PV}.tar.gz"
+
+LICENSE="zi-labone"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="mirror bindist"
+IUSE="minimal"
+
+QA_PREBUILT="*"
+
+RDEPEND=""
+
+S=${WORKDIR}/LabOneLinux64-${PV}
+
+src_install() {
+ local application_directory=/opt/zi
+ local installation_directory="${application_directory}/LabOne64-${PV}"
+
+ if ! use minimal ; then
+
+ # the applications
+
+ dodir ${installation_directory}
+ for dir in API DataServer Firmware Documentation WebServer ; do
+ mv "$dir" "${D}${installation_directory}/" || die
+ done
+
+ cp "release_notes_$(ver_cut 1-2).txt" "${D}${installation_directory}/" || die
+
+ dosym ../..${installation_directory}/DataServer/ziServer /opt/bin/ziServer
+ dosym ../..${installation_directory}/DataServer/ziDataServer /opt/bin/ziDataServer
+
+ # the services
+
+ # LabOne comes with systemd support.
+
+ local service
+ for service in labone-data-server hf2-data-server ; do
+ sed -e 's:/usr/local/bin/:/opt/bin/:g' -i Installer/systemd/${service}.service || die
+ systemd_dounit Installer/systemd/${service}.service
+ done
+
+ # For OpenRC we need to do our own thing...
+
+ for service in labone-data-server hf2-data-server ; do
+ doinitd "${FILESDIR}/${service}"
+ doconfd "${FILESDIR}/${service}.conf"
+ done
+
+ echo "#!/bin/bash" > "${T}/startziWebServer" || die
+ echo "${installation_directory}/WebServer/ziWebServer -r ${installation_directory}/WebServer/html --ip 127.0.0.1 --server-port 8004 -a 1" '$@ &' >> "${T}/startziWebServer" || die
+ chmod 755 "${T}/startziWebServer" || die
+ exeinto /opt/bin
+ doexe "${T}/startziWebServer"
+ elog For security reasons the startziWebServer script listens on the localhost interface only.
+
+ newicon "${D}${installation_directory}/WebServer/html/images/favicons/firefox_app_128x128.png" zi-labone.png
+
+ make_desktop_entry /opt/bin/startziWebServer "ZI LabOne" zi-labone "Science;Physics;Engineering"
+
+ else
+
+ insinto "${installation_directory}/API/C/lib"
+ doins API/C/lib/*.so
+ insinto "${installation_directory}/API/C/include"
+ doins API/C/include/*.h
+
+ fi
+
+ dosym "../..${installation_directory}/API/C/include/ziAPI.h" "usr/include/ziAPI.h"
+ dosym "../..${installation_directory}/API/C/lib/libziAPI-linux64.so" "usr/$(get_libdir)/libziAPI-linux64.so"
+
+ udev_dorules Installer/udev/55-zhinst.rules
+}