summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/splat/splat-1.4.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/splat/splat-1.4.2.ebuild')
-rw-r--r--sci-electronics/splat/splat-1.4.2.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/sci-electronics/splat/splat-1.4.2.ebuild b/sci-electronics/splat/splat-1.4.2.ebuild
new file mode 100644
index 000000000000..e302b4022a43
--- /dev/null
+++ b/sci-electronics/splat/splat-1.4.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool for the spectrum between 20 MHz and 20 GHz"
+HOMEPAGE="http://www.qsl.net/kd2bd/splat.html"
+SRC_URI="http://www.qsl.net/kd2bd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc hires linguas_es"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.2-gcc43.patch"
+}
+
+src_configure() {
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/splat.h"
+ /* Parameters for 3 arc-second standard resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 0
+ EOF
+ if use hires; then
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/hires.h"
+ /* Parameters for 3 arc-second hires resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 1
+ EOF
+ fi
+}
+
+src_compile() {
+
+ local CC=$(tc-getCC) CXX=$(tc-getCXX)
+
+ ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat -lm -lbz2 || die
+ if use hires; then
+ cp "${S}/hires.h" "${S}/splat.h"
+ ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat-hd -lm -lbz2 || die
+ fi
+
+ cd utils
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} citydecoder.c -o citydecoder
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} usgs2sdf.c -o usgs2sdf
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} srtm2sdf.c -o srtm2sdf -lbz2
+ #${CC} -Wall ${CFLAGS} ${LDFLAGS} fontdata.c -o fontdata -lz
+ ${CC} -Wall ${CFLAGS} ${LDFLAGS} bearing.c -o bearing -lm
+}
+
+src_install() {
+ local SPLAT_LANG="english"
+ use linguas_es && SPLAT_LANG="spanish"
+ # splat binary
+ dobin rfsplat
+ if use hires; then
+ dobin rfsplat-hd
+ fi
+
+ # utilities
+ dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing}
+ newman docs/${SPLAT_LANG}/man/splat.man rfsplat.1
+
+ dodoc CHANGES README utils/fips.txt
+ newdoc utils/README README.UTILS
+
+ if use doc; then
+ dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
+ fi
+ #sample data
+ docinto sample_data
+ dodoc sample_data/*
+}
+
+pkg_postinst() {
+ elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
+ elog "filename collission with app-portage/splat."
+ elog ""
+ elog "Be aware that it is still referenced as 'splat' in the documentation."
+}