summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonRB <jon.roadleybattin@gmail.com>2021-11-22 14:02:47 -0500
committerSam James <sam@gentoo.org>2021-11-23 17:15:36 +0000
commit3e4eff973b67436a6d227724008ff6435b6d42e4 (patch)
tree6dc75acbb8fac653f0d1eb9a7ec11ebcf7117133 /sci-electronics
parentsci-electronics/kicad: add 6.0.0_rc1 (diff)
downloadgentoo-3e4eff973b67436a6d227724008ff6435b6d42e4.tar.gz
gentoo-3e4eff973b67436a6d227724008ff6435b6d42e4.tar.bz2
gentoo-3e4eff973b67436a6d227724008ff6435b6d42e4.zip
sci-electronics/kicad-templates: add live 9999 version
Signed-off-by: JonRB <jon.roadleybattin@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-templates/kicad-templates-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-electronics/kicad-templates/kicad-templates-9999.ebuild b/sci-electronics/kicad-templates/kicad-templates-9999.ebuild
new file mode 100644
index 000000000000..348280a3c4d3
--- /dev/null
+++ b/sci-electronics/kicad-templates/kicad-templates-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools project templates"
+HOMEPAGE="https://github.com/kicad/kicad-templates"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/${PN}.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${MY_PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+
+RDEPEND=">=sci-electronics/kicad-5.99"