summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2020-10-05 21:57:26 +0800
committerJoonas Niilola <juippis@gentoo.org>2020-10-11 12:29:57 +0300
commit7dd65bdb230ff6e3b2647be30831397957f61fd6 (patch)
treebd7371869528a27659dc6ad4605d4998fe444687 /sci-electronics
parentapp-text/restview: correct DISTUTILS_USE_SETUPTOOLS, port to py3.9 (diff)
downloadgentoo-7dd65bdb230ff6e3b2647be30831397957f61fd6.tar.gz
gentoo-7dd65bdb230ff6e3b2647be30831397957f61fd6.tar.bz2
gentoo-7dd65bdb230ff6e3b2647be30831397957f61fd6.zip
sci-electronics/iverilog: bump to 11.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Huang Rui <vowstar@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/iverilog/Manifest1
-rw-r--r--sci-electronics/iverilog/iverilog-11.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-electronics/iverilog/Manifest b/sci-electronics/iverilog/Manifest
index 24a4970e513a..7fe42d17f047 100644
--- a/sci-electronics/iverilog/Manifest
+++ b/sci-electronics/iverilog/Manifest
@@ -1 +1,2 @@
DIST iverilog-10.3.tar.gz 1600835 BLAKE2B 107c57c61fb27c18f4020f7853bf6ca83d1a86fdc73c57ea207828baf6b7a26d42e43ce7b33580f050a4c0b8f63bca6accecf678323a3bbbee1eb9c1d8fa2caa SHA512 67076e19a208576c21a0462ff7d15d00a9d47740c47518a5523bd928b3118360d85eb84c317963717d15e5246ece3727259f6ff3baf59e195340530cc9086a1d
+DIST iverilog-11.0.tar.gz 1682457 BLAKE2B ba90574e1453a095143e76e5dc79bb2357a721fc62c24f0fb23d220458819cb3b8ea8494410ce956e68831b682b61f27f64e94e9c166a69e5f6d5d30a8269a11 SHA512 5d6a65e1c3b6b62e99af708cd5a259cc69c6b789dd6eff69e225903d9b8c115d9e5d6f7635b30c6558197cd0ee6fd8196a163fbd98956e24c211d97328b85056
diff --git a/sci-electronics/iverilog/iverilog-11.0.ebuild b/sci-electronics/iverilog/iverilog-11.0.ebuild
new file mode 100644
index 000000000000..2261c277e8c3
--- /dev/null
+++ b/sci-electronics/iverilog/iverilog-11.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+GITHUB_PV=$(ver_rs 1- '_')
+
+DESCRIPTION="A Verilog simulation and synthesis tool"
+HOMEPAGE="
+ http://iverilog.icarus.com
+ https://github.com/steveicarus/iverilog
+"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/steveicarus/${PN}.git"
+else
+ SRC_URI="https://github.com/steveicarus/${PN}/archive/v${GITHUB_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-${GITHUB_PV}"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="
+ sys-libs/readline:=
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gperf
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_prepare() {
+ default
+
+ # From upstreams autoconf.sh, to make it utilize the autotools eclass
+ # Here translate the autoconf.sh, equivalent to the following code
+ # > sh autoconf.sh
+
+ # Autoconf in root ...
+ eautoconf
+
+ # Precompiling lexor_keyword.gperf
+ gperf -o -i 7 -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
+ # Precompiling vhdlpp/lexor_keyword.gperf
+ cd vhdlpp || die
+ gperf -o -i 7 --ignore-case -C -k 1-4,6,9,\$ -H keyword_hash -N check_identifier -t ./lexor_keyword.gperf > lexor_keyword.cc || die
+}
+
+src_install() {
+ local DOCS=( *.txt )
+
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}