summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-12-08 12:07:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-12-08 12:08:16 +0200
commit817ff99534427a77a9f04b8e3b1b0ccad9f544f7 (patch)
treec118b48e9cd716867b9d327716aad00a39643cd8 /sci-electronics
parentsci-electronics/librepcb: bump version to 0.1.3 (diff)
downloadgentoo-817ff99534427a77a9f04b8e3b1b0ccad9f544f7.tar.gz
gentoo-817ff99534427a77a9f04b8e3b1b0ccad9f544f7.tar.bz2
gentoo-817ff99534427a77a9f04b8e3b1b0ccad9f544f7.zip
sci-electronics/librepcb: use xdg-utils.eclass
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.3.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sci-electronics/librepcb/librepcb-0.1.3.ebuild b/sci-electronics/librepcb/librepcb-0.1.3.ebuild
index 50dfacb22b3c..fe132f053703 100644
--- a/sci-electronics/librepcb/librepcb-0.1.3.ebuild
+++ b/sci-electronics/librepcb/librepcb-0.1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit qmake-utils
+inherit qmake-utils xdg-utils
DESCRIPTION="Free EDA software to develop printed circuit boards"
HOMEPAGE="https://librepcb.org/"
@@ -39,3 +39,15 @@ src_configure() {
src_install() {
emake INSTALL_ROOT="${D}" install
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}