summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-02-15 22:29:15 -0800
committerSam James <sam@gentoo.org>2023-02-17 05:09:38 +0000
commit9982574ee52d9ace95f1d100d3f3a8ab16d401b4 (patch)
tree51cb206dfbee79cf925637a4a943131ff702d7f8 /sci-electronics
parentsci-electronics/kicad: Update live ebuild (diff)
downloadgentoo-9982574ee52d9ace95f1d100d3f3a8ab16d401b4.tar.gz
gentoo-9982574ee52d9ace95f1d100d3f3a8ab16d401b4.tar.bz2
gentoo-9982574ee52d9ace95f1d100d3f3a8ab16d401b4.zip
sci-electronics/kicad: add 7.0.0
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Bug: https://bugs.gentoo.org/894660 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/Manifest1
-rw-r--r--sci-electronics/kicad/kicad-7.0.0.ebuild165
2 files changed, 166 insertions, 0 deletions
diff --git a/sci-electronics/kicad/Manifest b/sci-electronics/kicad/Manifest
index 8648f44a89ca..92a0c48e970f 100644
--- a/sci-electronics/kicad/Manifest
+++ b/sci-electronics/kicad/Manifest
@@ -1 +1,2 @@
DIST kicad-6.0.9.tar.gz 45166663 BLAKE2B e4d45c589a8e76d7c121ac4ab7adefc5fd44d4ccbff7140196caec56c309f6e83d47a3ea9cf79f59de57c3bda43b3d32a2bea82c5850c2a7a58a6e1db27a06a7 SHA512 49e6bd3c9f6e0c9839c4fac18dc12dc7ef16183f6fbe8091992e2223c7fb085b3119d46797c0b0cf86fd2813e3c4def9eb1f2adbff1bf072a363f1a501da9354
+DIST kicad-7.0.0.tar.bz2 42583715 BLAKE2B 24fefe73bce6254bb47fdf21e8a82b7752e3f58cb3ea61220f0cf008c6570a4378f15bad54b81cc9257ec223bdb6128ccfd33f356e738b112c7b0e9481257255 SHA512 cb6f4cf6eee9a583d3a622bf8e48e5b604b047df0d742081cff1e5e387cf97cc1cd3f03fb58a17b44c47085634b95eea642bd1a6805e80807dbe0473c8d19d96
diff --git a/sci-electronics/kicad/kicad-7.0.0.ebuild b/sci-electronics/kicad/kicad-7.0.0.ebuild
new file mode 100644
index 000000000000..96825330a19f
--- /dev/null
+++ b/sci-electronics/kicad/kicad-7.0.0.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+WX_GTK_VER="3.0-gtk3"
+
+inherit check-reqs cmake optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
+
+DESCRIPTION="Electronic Schematic and PCB design tools"
+HOMEPAGE="https://www.kicad.org"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/code/kicad.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/code/${PN}/-/archive/${MY_PV}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+fi
+
+# BSD for bundled pybind
+LICENSE="GPL-2+ GPL-3+ Boost-1.0 BSD"
+SLOT="0"
+IUSE="doc examples +ngspice nls openmp"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Contains bundled pybind but it's patched for wx
+# See https://gitlab.com/kicad/code/kicad/-/commit/74e4370a9b146b21883d6a2d1df46c7a10bd0424
+# Depend on opencascade:0 to get unslotted variant (so we know path to it), bug #833301
+COMMON_DEPEND="
+ dev-db/unixODBC
+ dev-libs/boost:=[context,nls]
+ media-libs/freeglut
+ media-libs/glew:0=
+ >=media-libs/glm-0.9.9.1
+ media-libs/mesa[X(+)]
+ net-misc/curl
+ >=sci-libs/opencascade-7.3.0:0=
+ >=x11-libs/cairo-1.8.8:=
+ >=x11-libs/pixman-0.30
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ sys-libs/zlib
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[context,nls,python,${PYTHON_USEDEP}]
+ dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ ngspice? (
+ >sci-electronics/ngspice-27[shared]
+ )
+ nls? (
+ sys-devel/gettext
+ )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sci-electronics/electronics-menu
+"
+BDEPEND=">=dev-lang/swig-4.0
+ doc? ( app-doc/doxygen )"
+
+if [[ ${PV} == 9999 ]] ; then
+ # x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi
+
+CHECKREQS_DISK_BUILD="900M"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
+ python-single-r1_pkg_setup
+ setup-wxwidgets
+ check-reqs_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ default_src_unpack
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local mycmakeargs=(
+ -DKICAD_DOCS="${EPREFIX}/usr/share/doc/${PN}-doc-${PV}"
+
+ -DKICAD_SCRIPTING_WXPYTHON=ON
+
+ -DKICAD_BUILD_I18N="$(usex nls)"
+ -DKICAD_I18N_UNIX_STRICT_PATH="$(usex nls)"
+
+ -DPYTHON_DEST="$(python_get_sitedir)"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+
+ -DKICAD_SPICE="$(usex ngspice)"
+
+ -DKICAD_INSTALL_DEMOS="$(usex examples)"
+ -DCMAKE_SKIP_RPATH="ON"
+
+ -DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
+ -DOCC_LIBRARY_DIR="${CASROOT}"/$(get_libdir)/opencascade
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doxygen-docs
+ fi
+}
+
+src_test() {
+ # Test cannot find library in Portage's sandbox. Let's create a link so test can run.
+ ln -s "${BUILD_DIR}/eeschema/_eeschema.kiface" "${BUILD_DIR}/qa/eeschema/_eeschema.kiface" || die
+
+ # LD_LIBRARY_PATH is there to help it pick up the just-built libraries
+ LD_LIBRARY_PATH="${BUILD_DIR}/3d-viewer/3d_cache/sg:${LD_LIBRARY_PATH}" cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+
+ if use doc ; then
+ dodoc uncrustify.cfg
+ cd Documentation || die
+ dodoc -r *.txt kicad_doxygen_logo.png notes_about_pcbnew_new_file_format.odt doxygen/.
+ fi
+}
+
+pkg_postinst() {
+ optfeature "Component symbols library" sci-electronics/kicad-symbols
+ optfeature "Component footprints library" sci-electronics/kicad-footprints
+ optfeature "3D models of components " sci-electronics/kicad-packages3d
+ optfeature "Project templates" sci-electronics/kicad-templates
+ optfeature "Different languages for GUI" sci-electronics/kicad-i18n
+ optfeature "Extended documentation" app-doc/kicad-doc
+ optfeature "Creating 3D models of components" media-gfx/wings
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}