summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-21 15:33:51 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:18:43 +0000
commite745728aee0d3a3457bc96558866b25b0d0a04b8 (patch)
tree599964336d132bc6d6c28632b333c255164a4d59 /sci-electronics
parentsci-libs/blis: Port to python 3.{8.9} (diff)
downloadgentoo-e745728aee0d3a3457bc96558866b25b0d0a04b8.tar.gz
gentoo-e745728aee0d3a3457bc96558866b25b0d0a04b8.tar.bz2
gentoo-e745728aee0d3a3457bc96558866b25b0d0a04b8.zip
sci-electronics/drahnr-oregano: Port to python 3.{8,9}
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild42
1 files changed, 16 insertions, 26 deletions
diff --git a/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild b/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild
index a432282c92f1..d07c379b648f 100644
--- a/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild
+++ b/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_7 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='threads(+)'
-inherit gnome2-utils python-any-r1 waf-utils xdg-utils
+inherit python-any-r1 waf-utils xdg
DESCRIPTION="Application for the schematic capturing and simulation of electrical circuits"
HOMEPAGE="https://github.com/drahnr/oregano"
@@ -17,29 +18,28 @@ KEYWORDS="amd64 ppc x86"
S="${WORKDIR}/oregano-${PV}"
-COMMON_DEP="dev-libs/glib:2
+DEPEND="
+ dev-libs/glib:2
dev-libs/libxml2:2
x11-libs/goocanvas:2.0
x11-libs/gtk+:3
x11-libs/gtksourceview:3.0"
-DEPEND="${COMMON_DEP}
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
dev-util/glib-utils
virtual/pkgconfig"
-RDEPEND="${COMMON_DEP}
- || ( gnome-base/dconf gnome-base/gconf )
+RDEPEND="${DEPEND}
+ || (
+ gnome-base/dconf
+ gnome-base/gconf
+ )
sci-electronics/electronics-menu"
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] ; then
- python-any-r1_pkg_setup
- fi
+src_configure() {
+ waf-utils_src_configure
}
-src_configure() { waf-utils_src_configure; }
-
src_install() {
waf-utils_src_install --no-xdg --no-install-gschema
docompress -x /usr/share/doc/${PF}/{dev-docs,sequence}
@@ -49,10 +49,7 @@ src_install() {
}
pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
elog "Note: You'll need to emerge your prefered simulation backend"
elog "such as sci-electronics/ngspice (preferred) or sci-electronics/gnucap"
@@ -60,10 +57,3 @@ pkg_postinst() {
elog "As an alternative generate a netlist and use sci-electronics/spice"
elog "from the command line for simulation."
}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}