summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-18 20:19:26 +0100
committerSam James <sam@gentoo.org>2021-08-18 20:22:53 +0100
commitfd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1 (patch)
tree2531f26430541979c1076d6d7cd950a4f5f52563 /sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
parentdev-libs/protobuf-c: add 1.4.0 (diff)
downloadgentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.tar.gz
gentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.tar.bz2
gentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.zip
sci-geosciences/foxtrotgps: add upstream patch for some receivers
I've rebased the patch myself and added an extra API check to be conservative as the patch didn't apply cleanly to the tarball. Thanks-to: Maciej S. Szmigiero <mail@maciej.szmigiero.name> Closes: https://bugs.gentoo.org/808883 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild')
-rw-r--r--sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..cc36b1da8d8e
--- /dev/null
+++ b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Easy to use, fast and lightweight mapping application (fork of tangogps)"
+HOMEPAGE="https://www.foxtrotgps.org/"
+SRC_URI="https://www.foxtrotgps.org/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ gnome-base/libglade
+ media-libs/libexif
+ net-misc/curl
+ >=sci-geosciences/gpsd-2.90:=
+ sys-apps/dbus
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gpsd-api9.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
+ "${FILESDIR}/${P}-fix-some-receivers.patch"
+)