summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-07 00:07:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-07 00:54:09 +0100
commite106187a132852c135da81fc6d7e54d07958805f (patch)
tree56ef268e7115d48879101c4392f3ca19428a8f38 /sci-geosciences/gebabbel/gebabbel-0.4.ebuild
parentapp-crypt/gnupg: Fix broken ssh without smartcard USE flag (diff)
downloadgentoo-e106187a132852c135da81fc6d7e54d07958805f.tar.gz
gentoo-e106187a132852c135da81fc6d7e54d07958805f.tar.bz2
gentoo-e106187a132852c135da81fc6d7e54d07958805f.zip
sci-geosciences/gebabbel: Bump to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences/gebabbel/gebabbel-0.4.ebuild')
-rw-r--r--sci-geosciences/gebabbel/gebabbel-0.4.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-geosciences/gebabbel/gebabbel-0.4.ebuild b/sci-geosciences/gebabbel/gebabbel-0.4.ebuild
index 671a59af4e38..38141acd13ba 100644
--- a/sci-geosciences/gebabbel/gebabbel-0.4.ebuild
+++ b/sci-geosciences/gebabbel/gebabbel-0.4.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
MY_P=${P/g/G}
-inherit eutils qt4-r2
+inherit qmake-utils
-DESCRIPTION="QT-Frontend to load and convert gps tracks with gpsbabel"
+DESCRIPTION="Qt-Frontend to load and convert gps tracks with gpsbabel"
HOMEPAGE="http://gebabbel.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}-Src.tar.gz"
@@ -24,21 +24,25 @@ RDEPEND="${DEPEND}
sci-geosciences/gpsbabel
"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.3-gcc45.patch
-)
+DOCS=( CHANGELOG CREDITS )
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3-gcc45.patch )
S=${WORKDIR}/${MY_P}
src_prepare() {
- qt4-r2_src_prepare
+ default
# do not mess with cflags
sed \
-e "/QMAKE_CXXFLAGS/s:=.*$:= ${CXXFLAGS}:g" \
-i *.pro || die
}
+src_configure() {
+ eqmake4 Gebabbel.pro
+}
+
src_install() {
dobin bin/${PN}
- dodoc CHANGELOG CREDITS
+ einstalldocs
}