summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 11:59:05 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:39:56 +0200
commit1883961e4551025475c5120ba76ecfee8f9a7b15 (patch)
tree3e2c6e8174ade4176fe5b5fc8792f65d8269bbdd /sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
parentsci-geosciences/geocode-glib: Drop old (diff)
downloadgentoo-1883961e4551025475c5120ba76ecfee8f9a7b15.tar.gz
gentoo-1883961e4551025475c5120ba76ecfee8f9a7b15.tar.bz2
gentoo-1883961e4551025475c5120ba76ecfee8f9a7b15.zip
sci-geosciences/geocode-glib: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
new file mode 100644
index 000000000000..a2a5922cbf24
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug does not do anything useful
+
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ gnome-base/gvfs[http]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3:=
+ net-libs/libsoup:2.4[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+# FIXME: need network #424719, recheck
+# need various locales to be present
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure $(use_enable introspection)
+}
+
+src_test() {
+ export GVFS_DISABLE_FUSE=1
+ export GIO_USE_VFS=gvfs
+ ewarn "Tests require network access to http://where.yahooapis.com"
+ dbus-launch emake check || die "tests failed"
+}