summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-01 21:06:44 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-01 21:18:11 -0500
commitaa3311232e12c2d683374e116fe7dbb8ec361164 (patch)
tree55d7209592b0b21975d1e7fb6ef629c01d0d5461 /sci-geosciences/gnome-maps
parentmedia-libs/libshumate: Version bump to 1.0.3 (diff)
downloadgentoo-aa3311232e12c2d683374e116fe7dbb8ec361164.tar.gz
gentoo-aa3311232e12c2d683374e116fe7dbb8ec361164.tar.bz2
gentoo-aa3311232e12c2d683374e116fe7dbb8ec361164.zip
sci-geosciences/gnome-maps: Version bump to 43.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch58
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-43.2.ebuild53
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index ae98f9e4d981..a848365a4616 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,4 @@
DIST gnome-maps-42.3.tar.xz 2317328 BLAKE2B 365eb5cb8f7b20e2069338249418f5fad1abd47a1ab7ecda2d671dc97dfa45fb9f5687ae01fd605613c7ecf6eb9048aef6ab121cac0f455a42df9156581c87e2 SHA512 e52509603914de8f345a874f931beb68d11f718827b956a48464fe804c42559d977eacb0bbd5d4346b6329ab3f9169ac9afa8ef681f040c5b6a82b440b9786cb
DIST gnome-maps-43.0.tar.xz 2330656 BLAKE2B 117a3558e29abe6a1bd29cf347b20a9e33f2b1cabd5310f28e387685e0bde96d1ce371c88616914f298e25ffbbc72b4d29e4fa721994b184e88289c6d0236ea0 SHA512 70966d6a092a67eb6a3a62627666376a71767d9296e00489a5aff281793425d9edd5e978deaf47bbd7d6b0ce37b53cf724b73487e101554c7984456661e193fc
DIST gnome-maps-43.1.tar.xz 2329212 BLAKE2B 6597597dcf5b056a33670f502c3ab0b9658b6cac5e72896f5363034649ddf01fe9ae2a275dbd1a298b0dd1850b8a9c625fff02a15c998fd0e296f794aedf7b0e SHA512 f4eafdf6b81a23567d526ae51842e391c7b3e585967abb2b6a38ab1a361de77a69ebbf01939f3a328990fe3f623f4bd40a720f776c27af07acb27b2222b75a12
+DIST gnome-maps-43.2.tar.xz 2334324 BLAKE2B a8daacd9874e9b8d44ae6107b7cc1a0a4a168d579b4101e4da408c08e2509f7da782605b27d089331d3628584783f3fd1d43c26d3bc7b09325810dec7b9b1648 SHA512 dfd7eba5fc0cc38152753d2d3b5ba13cdc614b96fe3f8e6629dc6c56515108fc6f2469f32629ffaba97667b15da294d874653d9133dd13592738379d5fb91c78
diff --git a/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch b/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
new file mode 100644
index 000000000000..95891953a30c
--- /dev/null
+++ b/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
@@ -0,0 +1,58 @@
+From bec3d2f26de1b3a8c8b7e603f6d6a46c853426fa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Pablo=20Correa=20G=C3=B3mez?= <ablocorrea@hotmail.com>
+Date: Fri, 28 Oct 2022 01:05:28 +0200
+Subject: [PATCH] tests/timeTest: Fix tests for time formats with different
+ kind of spaces
+
+Time.format does not warranty the character used for spaces, neither
+that it will not introduce preceding byte order marks. Solve it by
+comparing inclusion of the data and that it finishes with AM or PM.
+
+Closes #506
+---
+ tests/timeTest.js | 15 ++++++++++-----
+ 1 file changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/tests/timeTest.js b/tests/timeTest.js
+index 96803f2f..d025e8e8 100644
+--- a/tests/timeTest.js
++++ b/tests/timeTest.js
+@@ -23,6 +23,11 @@ const JsUnit = imports.jsUnit;
+
+ import * as Time from './time.js';
+
++function compare12HourTime(format, hoursMinutes, AMPM) {
++ JsUnit.assertTrue(format.includes(hoursMinutes));
++ JsUnit.assertTrue(format.endsWith(AMPM));
++}
++
+ function formatTimeWithTZOffsetTest() {
+ // mock to always use 24 hour format
+ Time._setIs12HourFunction(() => { return false; });
+@@ -35,8 +40,8 @@ function formatTimeWithTZOffsetTest() {
+ // mock to always use 12 hour format
+ Time._setIs12HourFunction(() => { return true; });
+
+- JsUnit.assertEquals('10:54 PM',
+- Time.formatTimeWithTZOffset(1607982864000, 3600000));
++ compare12HourTime(Time.formatTimeWithTZOffset(1607982864000, 3600000),
++ '10:54', 'PM');
+ }
+
+ function formatTimeFromHoursAndMinsTest() {
+@@ -50,9 +55,9 @@ function formatTimeFromHoursAndMinsTest() {
+ // mock to always use 12 hour format
+ Time._setIs12HourFunction(() => { return true; });
+
+- JsUnit.assertEquals('12:34 PM', Time.formatTimeFromHoursAndMins(12, 34));
+- JsUnit.assertEquals('12:00 AM', Time.formatTimeFromHoursAndMins(24, 0));
+- JsUnit.assertEquals('12:01 PM', Time.formatTimeFromHoursAndMins(12, 1));
++ compare12HourTime(Time.formatTimeFromHoursAndMins(12, 34), '12:34', 'PM');
++ compare12HourTime(Time.formatTimeFromHoursAndMins(24, 0), '12:00', 'AM');
++ compare12HourTime(Time.formatTimeFromHoursAndMins(12, 1), '12:01', 'PM');
+ }
+
+ formatTimeWithTZOffsetTest();
+--
+2.37.4
+
diff --git a/sci-geosciences/gnome-maps/gnome-maps-43.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-43.2.ebuild
new file mode 100644
index 000000000000..05e77806c2e9
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-43.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
+)
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}