summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-07-28 13:59:40 -0400
committerRick Farina <zerochaos@gentoo.org>2020-07-28 14:12:04 -0400
commit52d0dd930929ebc49804bd4a8ecfe674e8cff3cc (patch)
tree75ff8859f58f19178ea86f10178c7b33023f5d80 /sci-geosciences/gpsd/gpsd-9999.ebuild
parentacct-user/gpsd: migrating from user.eclass (diff)
downloadgentoo-52d0dd930929ebc49804bd4a8ecfe674e8cff3cc.tar.gz
gentoo-52d0dd930929ebc49804bd4a8ecfe674e8cff3cc.tar.bz2
gentoo-52d0dd930929ebc49804bd4a8ecfe674e8cff3cc.zip
sci-geosciences/gpsd: migrate to glep 81
add acct-user/gpsd and use it migrate from uucp/gpsd groups to dialout Interestingly I can't actually find gpsd group ever being created, but I find it being used. As such, I simply dropped it. https://bugs.gentoo.org/704580 https://bugs.gentoo.org/691746 https://bugs.gentoo.org/667410 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-9999.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 73c52f149eb1..f0fcb09fdae8 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7,8} )
SCONS_MIN_VERSION="2.3.0"
-inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
+inherit eutils udev multilib distutils-r1 scons-utils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -41,6 +41,7 @@ REQUIRED_USE="X? ( python )
RESTRICT="!test? ( test )"
RDEPEND="
+ acct-user/gpsd
>=net-misc/pps-tools-0.0.20120407
bluetooth? ( net-wireless/bluez )
dbus? (
@@ -135,7 +136,7 @@ src_configure() {
rundir="/run"
chrpath=False
gpsd_user=gpsd
- gpsd_group=uucp
+ gpsd_group=dialout
nostrip=True
manbuild=False
shared=$(usex !static True False)
@@ -190,9 +191,3 @@ src_install() {
use python && distutils-r1_src_install
}
-
-pkg_preinst() {
- # Run the gpsd daemon as gpsd and group uucp; create it here
- # as it doesn't seem to be needed during compile/install ...
- enewuser gpsd -1 -1 -1 "uucp"
-}