summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-20 13:22:29 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-20 13:22:29 +0100
commitb26523ae73e0c284269a287a0c1760680b57da1f (patch)
treeaf14eeec364e62723839b37b95467e12e5316625 /sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild
parentsci-physics/fastjet: Port to EAPI 7 (diff)
downloadgentoo-b26523ae73e0c284269a287a0c1760680b57da1f.tar.gz
gentoo-b26523ae73e0c284269a287a0c1760680b57da1f.tar.bz2
gentoo-b26523ae73e0c284269a287a0c1760680b57da1f.zip
sci-geosciences/gpx-viewer: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild')
-rw-r--r--sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild b/sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild
index 58e714a400e9..f46fb5bf69c7 100644
--- a/sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild
+++ b/sci-geosciences/gpx-viewer/gpx-viewer-0.4.0-r1.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-VALA_MIN_API_VERSION=0.16
-
-inherit autotools-utils gnome2 vala
+inherit gnome2 vala
DESCRIPTION="Simple program to visualize a gpx file"
HOMEPAGE="https://github.com/DaveDavenport/gpx-viewer"
-SRC_URI="https://edge.launchpad.net/${PN}/trunk/0.4.0/+download/${P}.tar.gz"
+SRC_URI="https://edge.launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,7 +21,8 @@ RDEPEND="
>=media-libs/clutter-gtk-1.4.0:1.0
>=media-libs/libchamplain-0.12.3:0.12[gtk]
x11-libs/gtk+:3"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
$(vala_depend)
>=dev-util/intltool-0.21
virtual/pkgconfig"
@@ -31,23 +30,22 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-crash-backport )
src_prepare() {
+ default
vala_src_prepare
- autotools-utils_src_prepare
}
src_configure() {
- local myeconfargs=(
- $(use_enable nls)
- --disable-database-updates )
- autotools-utils_src_configure
+ econf \
+ $(use_enable nls) \
+ --disable-database-updates
}
src_compile() {
- autotools-utils_src_compile gpx_viewer_vala.stamp
- autotools-utils_src_compile
+ emake gpx_viewer_vala.stamp
+ default
}
src_install() {
- autotools-utils_src_install
+ default
dosym ../icons/hicolor/scalable/apps/gpx-viewer.svg /usr/share/pixmaps/gpx-viewer.svg
}