summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-03-31 18:02:06 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-03-31 18:02:36 +0700
commit5958d0fd244c4297cef0af020d7a5cfcd0608d2b (patch)
tree0f38c754c360dac72cdabbc68a4c9a22973c9c41 /sci-geosciences/gpxsee/gpxsee-12.3.ebuild
parentdev-util/cdecl: add 14.0 (diff)
downloadgentoo-5958d0fd244c4297cef0af020d7a5cfcd0608d2b.tar.gz
gentoo-5958d0fd244c4297cef0af020d7a5cfcd0608d2b.tar.bz2
gentoo-5958d0fd244c4297cef0af020d7a5cfcd0608d2b.zip
sci-geosciences/gpxsee: bump to 12.3
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpxsee/gpxsee-12.3.ebuild')
-rw-r--r--sci-geosciences/gpxsee/gpxsee-12.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-geosciences/gpxsee/gpxsee-12.3.ebuild b/sci-geosciences/gpxsee/gpxsee-12.3.ebuild
new file mode 100644
index 000000000000..d3040a4c8b15
--- /dev/null
+++ b/sci-geosciences/gpxsee/gpxsee-12.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="ca cs da de en eo es fi fr hu it ko nb pl pt_BR ru sv tr uk zh"
+inherit plocale qmake-utils xdg
+
+MY_PN="GPXSee"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A viewer and analyzer that supports gpx, tcx, kml, fit, igc and nmea files"
+HOMEPAGE="https://www.gpxsee.org/"
+SRC_URI="https://github.com/tumic0/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtpositioning:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtserialport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=( "${FILESDIR}"/${PN}-7.33.patch )
+
+src_prepare() {
+ default
+
+ plocale_find_changes lang "${PN}_" '.ts'
+
+ rm_ts() {
+ sed -e "s|lang/gpxsee_${1}.ts||" -i gpxsee.pro
+ }
+
+ plocale_for_each_disabled_locale rm_ts
+}
+
+src_compile() {
+ $(qt5_get_bindir)/lrelease gpxsee.pro || die "lrelease failed"
+ eqmake5 gpxsee.pro
+ emake
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README.md
+}