summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Zigo <tomas.zigo@slovanet.sk>2021-09-19 17:17:35 +0200
committerSam James <sam@gentoo.org>2021-09-25 00:34:35 +0100
commite8cef9238270fcd394e032616ab9b9c3e420cdfc (patch)
tree96fa79ac8fe59d99469e28cc95197e0f7ee1b088 /sci-geosciences/grass
parentapp-crypt/coolkey: add missing autotools inherit (diff)
downloadgentoo-e8cef9238270fcd394e032616ab9b9c3e420cdfc.tar.gz
gentoo-e8cef9238270fcd394e032616ab9b9c3e420cdfc.tar.bz2
gentoo-e8cef9238270fcd394e032616ab9b9c3e420cdfc.zip
sci-geosciences/grass: fix install version 9999 (changes from 7.9 dev version to 8.0)
Closes: https://bugs.gentoo.org/813879 Signed-off-by: Tomas Zigo <tomas.zigo@slovanet.sk> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index a77634827df1..b0087078be5c 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite" # bug 572440
WANT_AUTOCONF="2.1"
WX_GTK_VER="3.0-gtk3"
inherit autotools desktop flag-o-matic git-r3 python-single-r1 toolchain-funcs wxwidgets xdg
-MY_P="${PN}7.9"
+MY_P="${PN}8.0"
MY_PM="${MY_P/.}"
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
@@ -216,6 +216,8 @@ src_install() {
sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
done
+ mv ${D}/usr/bin/grass ${D}/usr/bin/${MY_PM}
+
# get proper folder for grass path in script
local gisbase=/usr/$(get_libdir)/${MY_PM}
sed -e "s:GISBASE = os.path.normpath(\"${D}/usr/$(get_libdir)/${MY_PM}\"):\
@@ -232,9 +234,9 @@ GISBASE = os.path.normpath(\"${gisbase}\"):" \
os.environ\['GRASS_PYTHON'\] = \"${EPYTHON}\":" \
-i "${ED}"/usr/bin/${MY_PM} || die
- # set proper GISDBASE directory path in the demolocation .grassrc79 file
+ # set proper GISDBASE directory path in the demolocation .grassrc80 file
sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
- -i "${ED}"${gisbase}/demolocation/.grassrc79 || die
+ -i "${ED}"${gisbase}/demolocation/.grassrc80 || die
if use X; then
local GUI="-gui"