summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild')
-rw-r--r--sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild b/sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild
new file mode 100644
index 000000000000..97f71518ee19
--- /dev/null
+++ b/sci-geosciences/merkaartor/merkaartor-0.18.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+REDMINE_HASH="301"
+
+inherit multilib qt4-r2 ${SCM_ECLASS}
+
+DESCRIPTION="A Qt4 based map editor for the openstreetmap.org project"
+HOMEPAGE="http://www.merkaartor.be"
+SRC_URI="http://merkaartor.be/attachments/download/${REDMINE_HASH}/merkaartor-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug exif gps nls libproxy"
+
+QT_MINIMAL="4.7.2"
+DEPEND="
+ >=dev-libs/boost-1.46
+ >=sci-libs/gdal-1.6.0
+ >=sci-libs/proj-4.6
+ >=dev-qt/qtgui-${QT_MINIMAL}:4
+ >=dev-qt/qtsvg-${QT_MINIMAL}:4
+ >=dev-qt/qtwebkit-${QT_MINIMAL}:4
+ exif? ( media-gfx/exiv2 )
+ gps? ( >=sci-geosciences/gpsd-2.92[cxx] )
+ libproxy? ( net-libs/libproxy )
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS CHANGELOG HACKING"
+
+PATCHES=(
+# "${FILESDIR}"/0.17.2-includes.patch
+# "${FILESDIR}"/0.17.2-libproxy.patch
+)
+
+merkaartor_use() {
+ local useflag=${1}
+ [[ -z ${useflag} ]] && die "No useflag specified"
+ if use ${useflag}; then
+ echo "1"
+ else
+ echo "0"
+ fi
+}
+
+src_configure() {
+ local myconf
+ myconf+=" RELEASE=1 ZBAR=0" # deps not in main tree so hard-disable
+ myconf+=" GEOIMAGE=$(${PN}_use exif)"
+ myconf+=" GPSDLIB=$(${PN}_use gps)"
+ myconf+=" LIBPROXY=$(${PN}_use libproxy)"
+ myconf+=" NODEBUG=$(use debug && echo "0" || echo "1")" # inverse logic
+ myconf+=" NOUSEWEBKIT=0" # fails to link if disabled, upstream needs to fix
+ myconf+=" TRANSDIR_MERKAARTOR=/usr/share/${PN}/translations TRANSDIR_SYSTEM=/usr/share/qt4/translations" #385671
+
+ if use nls; then
+ lrelease src/src.pro || die "lrelease failed"
+ fi
+
+ eqmake4 Merkaartor.pro LIBDIR=/usr/$(get_libdir) PREFIX=/usr/ ${myconf}
+}