summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/merkaartor/merkaartor-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/merkaartor/merkaartor-9999.ebuild')
-rw-r--r--sci-geosciences/merkaartor/merkaartor-9999.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/sci-geosciences/merkaartor/merkaartor-9999.ebuild b/sci-geosciences/merkaartor/merkaartor-9999.ebuild
new file mode 100644
index 000000000000..633d069906c1
--- /dev/null
+++ b/sci-geosciences/merkaartor/merkaartor-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar cs de es et fr hr hu it ja nl pl pt_BR pt ru sk sv uk"
+
+inherit eutils fdo-mime gnome2-utils git-r3 l10n multilib qt4-r2
+
+DESCRIPTION="A Qt4 based map editor for the openstreetmap.org project"
+HOMEPAGE="http://www.merkaartor.be https://github.com/openstreetmap/merkaartor"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/openstreetmap/merkaartor.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug exif gps libproxy qrcode"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+ >=dev-qt/qtsingleapplication-2.6.1[X,qt4(+)]
+ >=dev-libs/quazip-0.7[qt4(+)]
+ >=sci-libs/gdal-1.6.0
+ >=sci-libs/proj-4.6
+ sys-libs/zlib
+ exif? ( media-gfx/exiv2:= )
+ gps? ( >=sci-geosciences/gpsd-2.92[cxx] )
+ libproxy? ( net-libs/libproxy )
+ qrcode? ( media-gfx/zbar )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS CHANGELOG HACKING )
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ my_rm_loc() {
+ sed -i -e "s:../translations/${PN}_${1}.\(ts\|qm\)::" src/src.pro || die
+ rm "translations/${PN}_${1}.ts" || die
+ }
+
+ l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
+
+ if [[ -n "$(l10n_get_locales)" ]]; then
+ l10n_for_each_disabled_locale_do my_rm_loc
+ $(qt4_get_bindir)/lrelease src/src.pro || die
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ # TRANSDIR_SYSTEM is for bug #385671
+ eqmake4 \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ TRANSDIR_MERKAARTOR="${EPREFIX}/usr/share/${PN}/translations" \
+ TRANSDIR_SYSTEM="${EPREFIX}/usr/share/qt4/translations" \
+ SYSTEM_QTSA=1 \
+ SYSTEM_QUAZIP=1 \
+ NODEBUG="$(usex debug '0' '1')" \
+ GEOIMAGE="$(usex exif '1' '0')" \
+ GPSDLIB="$(usex gps '1' '0')" \
+ LIBPROXY="$(usex libproxy '1' '0')" \
+ ZBAR="$(usex qrcode '1' '0')" \
+ Merkaartor.pro
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}