summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-30 22:37:32 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-31 00:03:18 +0100
commit4fcba282c4c48ea4083c95f711889ccee249312f (patch)
treee60e9a5c8c3da9c0126b76b6a93a9f1a55977127 /sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
parentapp-emulation/wine: update to use multilib_foreach_abi in src_install (diff)
downloadgentoo-4fcba282c4c48ea4083c95f711889ccee249312f.tar.gz
gentoo-4fcba282c4c48ea4083c95f711889ccee249312f.tar.bz2
gentoo-4fcba282c4c48ea4083c95f711889ccee249312f.zip
sci-geosciences/opencpn-plugin-gxradar: added new plugin
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
new file mode 100644
index 000000000000..01ad84dc49d6
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="gxradar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/trudK45/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/trudK45/${MY_PN}/archive/v.${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Garmin xHD Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/trudK45/gxradar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}