summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-04 22:20:11 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-04 22:20:11 +0200
commit8416e5adff53fd466a318ccbdd1bbe3d5c93a2f7 (patch)
treea912883027d2d3e950a866ed88a650a7faa393d6 /sci-geosciences/opencpn-plugin-launcher
parentsci-geosciences/opencpn-plugin-iacfleet: need-wxwidgets -> setup-wxwidgets (diff)
downloadgentoo-8416e5adff53fd466a318ccbdd1bbe3d5c93a2f7.tar.gz
gentoo-8416e5adff53fd466a318ccbdd1bbe3d5c93a2f7.tar.bz2
gentoo-8416e5adff53fd466a318ccbdd1bbe3d5c93a2f7.zip
sci-geosciences/opencpn-plugin-launcher: need-wxwidgets -> setup-wxwidgets
Bug: https://bugs.gentoo.org/770622 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-geosciences/opencpn-plugin-launcher')
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild27
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-9999.ebuild27
2 files changed, 26 insertions, 28 deletions
diff --git a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
index 4a8ac8778e36..642568c3b3df 100644
--- a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
+++ b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="launcher_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/nohal/launcher_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}
diff --git a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-9999.ebuild b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-9999.ebuild
index 4a8ac8778e36..642568c3b3df 100644
--- a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="launcher_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/nohal/launcher_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}