summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Schlupp <nils.schlupp@gmail.com>2022-05-06 17:27:17 -0700
committerMarc Schiffbauer <mschiff@gentoo.org>2022-05-17 23:16:29 -1000
commit4b231eb29a9468c51f033ef90b0e211c8e77ee12 (patch)
treeac6214420c12c2b6ed91b03e91bd695c78b14625 /sci-geosciences/opencpn-plugin-weather_routing
parentsci-geosciences/opencpn: update EAPI 7 -> 8 (diff)
downloadgentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.tar.gz
gentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.tar.bz2
gentoo-4b231eb29a9468c51f033ef90b0e211c8e77ee12.zip
sci-geosciences/opencpn-plugin-weather_routing:
Switching to more recent maintainer branch and bumping to version 1.13.1 Bug: https://bugs.gentoo.org/830067,https://bugs.gentoo.org/831680 Signed-off-by: Nils Schlupp <nils.schlupp@gmail.com> Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weather_routing')
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/Manifest2
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild35
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild8
3 files changed, 40 insertions, 5 deletions
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/Manifest b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
index 8ef5e1f39a73..a8d3887396a5 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/Manifest
+++ b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
@@ -1 +1 @@
-DIST opencpn-plugin-weather_routing-1.10.1.tar.gz 845403 BLAKE2B e7cacef78f2f5567c008452c6c24eacf3acde8f8dcd78aa05f1e36248f31ab946f27c0bacdbb0882dcc1075a0fe15d6ddd62f5e24f7c38fffaf577683de6a345 SHA512 052377bc2b962b131640ecdb2e688b97325a7935f60c68652be6bdb07486278d03d09ec2c8b4b1547e5eeab1ea7613890604c800a91f185babe5bfb5221a7337
+DIST opencpn-plugin-weather_routing-1.13.1.tar.gz 893533 BLAKE2B 011eed0e6c4b463a89e83611f1b5b6dcb74edd65100a8fe444c5623ea85c20666194586964c2ed0b8a8b1d2d790026affccc034d98ea375284048fd33983a092 SHA512 43661df7b1a823f38a928a899bca58cd7451b663e23843bdf79000c0bc4e95cf9491e21e7a5ea6ad33f6a15e0a72c68058779ee241ad338a907852d048b5bc45
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
new file mode 100644
index 000000000000..586c24e8abcb
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
+MY_PN="weather_routing_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rgleason/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/rgleason/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weather Routing Plugin for OpenCPN"
+HOMEPAGE="https://github.com/rgleason/weather_routing_pi/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
index 826df2e8f0ba..586c24e8abcb 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,16 +9,16 @@ inherit cmake wxwidgets
MY_PN="weather_routing_pi"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/rgleason/${MY_PN}.git"
else
- SRC_URI="https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/rgleason/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
DESCRIPTION="Weather Routing Plugin for OpenCPN"
-HOMEPAGE="https://github.com/seandepagnier/weather_routing_pi/"
+HOMEPAGE="https://github.com/rgleason/weather_routing_pi/"
LICENSE="GPL-3+"
SLOT="0"