summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-01 20:08:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-02 20:39:14 +0100
commit6516010356d81151671b063357aff47bca18b86c (patch)
tree319712dcd4e6632aea4560b31805942768d2db4b /sci-geosciences/qgis/files
parentgames-engines/openmw: Drop old (diff)
downloadgentoo-6516010356d81151671b063357aff47bca18b86c.tar.gz
gentoo-6516010356d81151671b063357aff47bca18b86c.tar.bz2
gentoo-6516010356d81151671b063357aff47bca18b86c.zip
sci-geosciences/qgis: Drop old
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4099
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-1.7.0-avoid-deprecated-pyqtconfig.patch53
-rw-r--r--sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch54
-rw-r--r--sci-geosciences/qgis/files/qgis-1.8.0-private.patch10
-rw-r--r--sci-geosciences/qgis/files/qgis-1.8.0-redrawning.patch10
4 files changed, 0 insertions, 127 deletions
diff --git a/sci-geosciences/qgis/files/qgis-1.7.0-avoid-deprecated-pyqtconfig.patch b/sci-geosciences/qgis/files/qgis-1.7.0-avoid-deprecated-pyqtconfig.patch
deleted file mode 100644
index 65cabb2afe72..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.7.0-avoid-deprecated-pyqtconfig.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Avoid relying on the deprecated pyqtconfig module.
-
-When PyQt4 is configured using configure-ng.py then no pyqtconfig module
-will be built, causing the automatic detection in the QGIS build system to
-fail.
-
-This change tries to work around the problem by extracting or guessing all
-the relevant settings. It should work reasonably well for a default
-configuration of PyQt, but may fail if PyQt overrides the defaults from sip.
-All may break if SIP v5 is used, since that version apparently won't contain
-a sipconfig module any more. But we'll tackle that once we get there.
-
-References:
-* https://bugs.gentoo.org/show_bug.cgi?id=525700
-
-2014-10-21 Martin von Gagern
-
-Index: qgis-2.4.0/cmake/FindPyQt.py
-===================================================================
---- qgis-2.4.0.orig/cmake/FindPyQt.py
-+++ qgis-2.4.0/cmake/FindPyQt.py
-@@ -30,9 +30,29 @@
- # Redistribution and use is allowed according to the terms of the BSD license.
- # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
-
--import PyQt4.pyqtconfig
-+try:
-+ import PyQt4.pyqtconfig
-+ pyqtcfg = PyQt4.pyqtconfig.Configuration()
-+except ImportError:
-+ import PyQt4.QtCore
-+ import sipconfig # won't work for SIP v5
-+ import os.path
-+ cfg = sipconfig.Configuration()
-+ sip_dir = cfg.default_sip_dir
-+ for p in (os.path.join(sip_dir, "PyQt4"), sip_dir):
-+ if os.path.exists(os.path.join(p, "QtCore", "QtCoremod.sip")):
-+ sip_dir = p
-+ break
-+ cfg = {
-+ 'pyqt_version': PyQt4.QtCore.PYQT_VERSION,
-+ 'pyqt_version_str': PyQt4.QtCore.PYQT_VERSION_STR,
-+ 'pyqt_sip_flags': PyQt4.QtCore.PYQT_CONFIGURATION['sip_flags'],
-+ 'pyqt_mod_dir': cfg.default_mod_dir,
-+ 'pyqt_sip_dir': sip_dir,
-+ 'pyqt_bin_dir': cfg.default_bin_dir,
-+ }
-+ pyqtcfg = sipconfig.Configuration([cfg])
-
--pyqtcfg = PyQt4.pyqtconfig.Configuration()
- print("pyqt_version:%06.0x" % pyqtcfg.pyqt_version)
- print("pyqt_version_num:%d" % pyqtcfg.pyqt_version)
- print("pyqt_version_str:%s" % pyqtcfg.pyqt_version_str)
diff --git a/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch b/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch
deleted file mode 100644
index ec3e1c2dccf6..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- cmake/PythonMacros.cmake
-+++ cmake/PythonMacros.cmake
-@@ -22,40 +22,4 @@
- # Install the source file.
- INSTALL(FILES ${SOURCE_FILE} DESTINATION ${DESINATION_DIR})
-
-- # Byte compile and install the .pyc file.
-- GET_FILENAME_COMPONENT(_absfilename ${SOURCE_FILE} ABSOLUTE)
-- GET_FILENAME_COMPONENT(_filename ${SOURCE_FILE} NAME)
-- GET_FILENAME_COMPONENT(_filenamebase ${SOURCE_FILE} NAME_WE)
-- GET_FILENAME_COMPONENT(_basepath ${SOURCE_FILE} PATH)
--
-- if(WIN32)
-- string(REGEX REPLACE ".:/" "/" _basepath "${_basepath}")
-- endif(WIN32)
--
-- SET(_bin_py ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filename})
-- SET(_bin_pyc ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyc)
--
-- FILE(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${_basepath})
--
-- SET(_message "-DMESSAGE=Byte-compiling ${_bin_py}")
--
-- GET_FILENAME_COMPONENT(_abs_bin_py ${_bin_py} ABSOLUTE)
-- IF(_abs_bin_py STREQUAL ${_absfilename}) # Don't copy the file onto itself.
-- ADD_CUSTOM_COMMAND(
-- TARGET compile_python_files
-- COMMAND ${CMAKE_COMMAND} -E echo ${message}
-- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-- DEPENDS ${_absfilename}
-- )
-- ELSE(_abs_bin_py STREQUAL ${_absfilename})
-- ADD_CUSTOM_COMMAND(
-- TARGET compile_python_files
-- COMMAND ${CMAKE_COMMAND} -E echo ${message}
-- COMMAND ${CMAKE_COMMAND} -E copy ${_absfilename} ${_bin_py}
-- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-- DEPENDS ${_absfilename}
-- )
-- ENDIF(_abs_bin_py STREQUAL ${_absfilename})
--
-- INSTALL(FILES ${_bin_pyc} DESTINATION ${DESINATION_DIR})
- ENDMACRO(PYTHON_INSTALL)
---- python/CMakeLists.txt
-+++ python/CMakeLists.txt
-@@ -102,8 +102,6 @@
-
- SET (QGIS_PYTHON_DIR ${PYTHON_SITE_PACKAGES_DIR}/qgis)
-
--ADD_CUSTOM_TARGET(compile_python_files ALL)
--
- ADD_CUSTOM_COMMAND(TARGET compile_python_files
- POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E make_directory ${QGIS_PYTHON_OUTPUT_DIRECTORY}
diff --git a/sci-geosciences/qgis/files/qgis-1.8.0-private.patch b/sci-geosciences/qgis/files/qgis-1.8.0-private.patch
deleted file mode 100644
index 59c3ca769397..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.8.0-private.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/core/qgsmaplayerregistry.h 2015-12-30 15:06:17.199889612 +0100
-+++ b/src/core/qgsmaplayerregistry.h 2015-12-30 15:05:50.159890061 +0100
-@@ -173,6 +173,7 @@
- /** debugging member
- invoked when a connect() is made to this object
- */
-+ public:
- void connectNotify( const char * signal );
-
-
diff --git a/sci-geosciences/qgis/files/qgis-1.8.0-redrawning.patch b/sci-geosciences/qgis/files/qgis-1.8.0-redrawning.patch
deleted file mode 100644
index b58ec55f1641..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.8.0-redrawning.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/gui/qgsmaptoolpan.cpp 2012-06-12 21:28:18.000000000 +0200
-+++ b/src/gui/qgsmaptoolpan.cpp 2015-12-30 15:55:02.679840978 +0100
-@@ -39,6 +39,7 @@
- mDragging = true;
- // move map and other canvas items
- mCanvas->panAction( e );
-+ mCanvas->refresh();
- }
- }
-