summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-07 18:02:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-12 23:42:15 +0200
commit91435c00d97ec375328fdc6b56d03fb98e0b4adc (patch)
tree8f46ea1e28a2c399b7b36009fe2cabbf1e2d0432 /sci-geosciences/qgis/files
parentapp-crypt/mit-krb5: properly detect LibreSSL version (diff)
downloadgentoo-91435c00d97ec375328fdc6b56d03fb98e0b4adc.tar.gz
gentoo-91435c00d97ec375328fdc6b56d03fb98e0b4adc.tar.bz2
gentoo-91435c00d97ec375328fdc6b56d03fb98e0b4adc.zip
sci-geosciences/qgis: Drop Qt4-based 2.8.{12,16}
Closes: https://bugs.gentoo.org/635798 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-2.18.12-sip.patch185
-rw-r--r--sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch31
2 files changed, 0 insertions, 216 deletions
diff --git a/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch b/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch
deleted file mode 100644
index 07db9b029bf6..000000000000
--- a/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch
+++ /dev/null
@@ -1,185 +0,0 @@
-diff --git a/python/core/conversions.sip b/python/core/conversions.sip
-index f07d3ab1db..948821e91e 100644
---- a/python/core/conversions.sip
-+++ b/python/core/conversions.sip
-@@ -2041,3 +2041,178 @@ register_from_qvariant_convertor = (void (*)(FromQVariantConvertorFn))sipImportS
- register_from_qvariant_convertor(null_from_qvariant_convertor);
- %End
- %End
-+
-+// QList<QVariant> is implemented as a Python list.
-+%MappedType QList<QVariant> /TypeHintIn="Sequence[QVariant]", TypeHintOut="List[QVariant]", TypeHintValue="[]"/
-+{
-+%TypeHeaderCode
-+#include <qlist.h>
-+%End
-+
-+%ConvertFromTypeCode
-+ // Create the list.
-+ PyObject *l;
-+
-+ if ((l = PyList_New(sipCpp->size())) == NULL)
-+ return NULL;
-+
-+ // Set the list elements.
-+ for (int i = 0; i < sipCpp->size(); ++i)
-+ {
-+ QVariant *t = new QVariant(sipCpp->at(i));
-+ PyObject *tobj;
-+
-+ if ((tobj = sipConvertFromNewType(t, sipType_QVariant, sipTransferObj)) == NULL)
-+ {
-+ Py_DECREF(l);
-+ delete t;
-+
-+ return NULL;
-+ }
-+
-+ PyList_SET_ITEM(l, i, tobj);
-+ }
-+
-+ return l;
-+%End
-+
-+%ConvertToTypeCode
-+ SIP_SSIZE_T len;
-+
-+ // Check the type if that is all that is required.
-+ if (sipIsErr == NULL)
-+ {
-+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
-+ return 0;
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ bool ok = (itm && sipCanConvertToType(itm, sipType_QVariant, SIP_NOT_NONE));
-+
-+ Py_XDECREF(itm);
-+
-+ if (!ok)
-+ return 0;
-+ }
-+
-+ return 1;
-+ }
-+
-+ QList<QVariant> *ql = new QList<QVariant>;
-+ len = PySequence_Size(sipPy);
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ int state;
-+ QVariant *t = reinterpret_cast<QVariant *>(sipConvertToType(itm, sipType_QVariant, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
-+
-+ Py_DECREF(itm);
-+
-+ if (*sipIsErr)
-+ {
-+ sipReleaseType(t, sipType_QVariant, state);
-+
-+ delete ql;
-+ return 0;
-+ }
-+
-+ ql->append(*t);
-+
-+ sipReleaseType(t, sipType_QVariant, state);
-+ }
-+
-+ *sipCppPtr = ql;
-+
-+ return sipGetState(sipTransferObj);
-+%End
-+};
-+
-+
-+// QList<QPolygonF> is implemented as a Python list.
-+%MappedType QList<QPolygonF> /TypeHintIn="Sequence[QPolygonF]", TypeHintOut="List[QPolygonF]", TypeHintValue="[]"/
-+{
-+%TypeHeaderCode
-+#include <qlist.h>
-+%End
-+
-+%ConvertFromTypeCode
-+ // Create the list.
-+ PyObject *l;
-+
-+ if ((l = PyList_New(sipCpp->size())) == NULL)
-+ return NULL;
-+
-+ // Set the list elements.
-+ for (int i = 0; i < sipCpp->size(); ++i)
-+ {
-+ QPolygonF *t = new QPolygonF(sipCpp->at(i));
-+ PyObject *tobj;
-+
-+ if ((tobj = sipConvertFromNewType(t, sipType_QPolygonF, sipTransferObj)) == NULL)
-+ {
-+ Py_DECREF(l);
-+ delete t;
-+
-+ return NULL;
-+ }
-+
-+ PyList_SET_ITEM(l, i, tobj);
-+ }
-+
-+ return l;
-+%End
-+
-+%ConvertToTypeCode
-+ SIP_SSIZE_T len;
-+
-+ // Check the type if that is all that is required.
-+ if (sipIsErr == NULL)
-+ {
-+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
-+ return 0;
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ bool ok = (itm && sipCanConvertToType(itm, sipType_QPolygonF, SIP_NOT_NONE));
-+
-+ Py_XDECREF(itm);
-+
-+ if (!ok)
-+ return 0;
-+ }
-+
-+ return 1;
-+ }
-+
-+ QList<QPolygonF> *ql = new QList<QPolygonF>;
-+ len = PySequence_Size(sipPy);
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ int state;
-+ QPolygonF *t = reinterpret_cast<QPolygonF *>(sipConvertToType(itm, sipType_QPolygonF, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
-+
-+ Py_DECREF(itm);
-+
-+ if (*sipIsErr)
-+ {
-+ sipReleaseType(t, sipType_QPolygonF, state);
-+
-+ delete ql;
-+ return 0;
-+ }
-+
-+ ql->append(*t);
-+
-+ sipReleaseType(t, sipType_QPolygonF, state);
-+ }
-+
-+ *sipCppPtr = ql;
-+
-+ return sipGetState(sipTransferObj);
-+%End
-+};
---
-2.12.0
diff --git a/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch b/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch
deleted file mode 100644
index 0d4c99de9de0..000000000000
--- a/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 70505aa1569c541dd252115848f46f91811955c0 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 9 Apr 2017 20:21:28 +0200
-Subject: [PATCH 1/2] Use FeatureSummary
-
----
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ed0a84013a..26f4659f61 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -28,6 +28,8 @@ SET(CMAKE_COLOR_MAKEFILE ON)
- # set path to additional CMake modules
- SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
-
-+include(FeatureSummary)
-+
- # in generated makefiles use relative paths so the project dir is moveable
- # Note commented out since it cause problems but it would be nice to resolve these and enable
- #
-@@ -908,3 +910,5 @@ ENDIF(WIN32 AND NOT UNIX)
- SET(CPACK_PACKAGE_EXECUTABLES "qgis" "QGIS")
- SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_SOURCE_DIR}/README.md")
- INCLUDE(CPack)
-+
-+FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---
-2.12.2
-