summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-10-24 17:24:30 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-10-24 17:24:30 +0700
commit8b549d5e1df24d0d3a36e7454b84d04f7bec281b (patch)
tree70a1d9edbefd30c6d76e621e5ef8feaeed5f465d /sci-geosciences/routino/routino-3.2.ebuild
parentdev-perl/Getopt-GUI-Long: keyword ~arm (diff)
downloadgentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.tar.gz
gentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.tar.bz2
gentoo-8b549d5e1df24d0d3a36e7454b84d04f7bec281b.zip
sci-geosciences/routino: making QA checks happy
Suggested-by: Fabio Rossi <rossi.f@inwind.it> Closes: https://bugs.gentoo.org/628398 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-geosciences/routino/routino-3.2.ebuild')
-rw-r--r--sci-geosciences/routino/routino-3.2.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/sci-geosciences/routino/routino-3.2.ebuild b/sci-geosciences/routino/routino-3.2.ebuild
index cb1ceff2cd3c..19512b20efa7 100644
--- a/sci-geosciences/routino/routino-3.2.ebuild
+++ b/sci-geosciences/routino/routino-3.2.ebuild
@@ -1,7 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
@@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-PATCHES=( "${FILESDIR}"/${P}.patch )
-src_configure() {
- :
+src_prepare() {
+ eapply "${FILESDIR}"/${P}.patch
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+
+ eapply_user
}
src_compile() {