summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-04-30 00:30:58 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-04-30 00:30:58 +0700
commited7ed0dae0b40b333a6f0cf863e8b2f2c931083a (patch)
tree52928a862d08fb3bd91caab032ebeb693ddc13be /sci-geosciences/routino/routino-3.3.2.ebuild
parentwww-client/opera: Version 68.0.3618.63 (diff)
downloadgentoo-ed7ed0dae0b40b333a6f0cf863e8b2f2c931083a.tar.gz
gentoo-ed7ed0dae0b40b333a6f0cf863e8b2f2c931083a.tar.bz2
gentoo-ed7ed0dae0b40b333a6f0cf863e8b2f2c931083a.zip
sci-geosciences/routino: bump to 3.3.2
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/routino/routino-3.3.2.ebuild')
-rw-r--r--sci-geosciences/routino/routino-3.3.2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-geosciences/routino/routino-3.3.2.ebuild b/sci-geosciences/routino/routino-3.3.2.ebuild
new file mode 100644
index 000000000000..bdab33b5a513
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.3.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="http://www.routino.org/"
+SRC_URI="http://www.routino.org/download/${P}.tgz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DEPEND="python? ( ${PYTHON_DEPS}
+ dev-lang/swig )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}.patch
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+
+ eapply_user
+}
+
+src_compile() {
+ emake -j1
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+ if use python; then
+ pushd python > /dev/null
+ python_compile() {
+ rm -f build/.timestamp
+ emake PYTHON=${EPYTHON}
+ }
+ python_foreach_impl python_compile
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ emake test
+# if use python; then
+# pushd python > /dev/null
+# python_test() {
+# echo "######## ${EPYTHON} ########"
+# emake PYTHON=${EPYTHON} test
+# }
+# python_foreach_impl python_test
+# popd > /dev/null
+# fi
+}
+
+src_install() {
+ default
+ if use python; then
+ pushd python > /dev/null
+ python_install() {
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl python_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null
+ fi
+
+}