summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-01-04 15:25:30 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-01-04 15:26:54 +0600
commitfe8080a62239979335fd328c29753618eb03b7e9 (patch)
tree5241c1d0439c44f04817d85e6c482149e869c73a /sci-geosciences/routino
parentmedia-gfx/geeqie: fix keywords widget with GTK3 (diff)
downloadgentoo-fe8080a62239979335fd328c29753618eb03b7e9.tar.gz
gentoo-fe8080a62239979335fd328c29753618eb03b7e9.tar.bz2
gentoo-fe8080a62239979335fd328c29753618eb03b7e9.zip
sci-geosciences/routino: initial import 3.0_p1
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest1
-rw-r--r--sci-geosciences/routino/files/makefile-conf.patch35
-rw-r--r--sci-geosciences/routino/metadata.xml17
-rw-r--r--sci-geosciences/routino/routino-3.0_p1.ebuild23
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
new file mode 100644
index 000000000000..222a9cc2d6e8
--- /dev/null
+++ b/sci-geosciences/routino/Manifest
@@ -0,0 +1 @@
+DIST routino-3.0_p1.tgz 957022 SHA256 037892a09cf2bb790d895d218a80c221e9595a3943ca35163c71ed93b111431e SHA512 be6275e8fcc0fe535a0940ba26fdf8e8ecfde768e4b2baaabf088a39431dc259933c3aa02ff3e28c5bf145402d18e6369a16d2c7a50fd1b84695dd31c155341f WHIRLPOOL 1e097aaa00437e08b485f4ce9d027cb31f3e320b5f61883a230ad235ccea8ca53c79bf0e428013434b91d0533f1212c43dd8a9f05eec2394cced070f83eb61ef
diff --git a/sci-geosciences/routino/files/makefile-conf.patch b/sci-geosciences/routino/files/makefile-conf.patch
new file mode 100644
index 000000000000..ca751312890f
--- /dev/null
+++ b/sci-geosciences/routino/files/makefile-conf.patch
@@ -0,0 +1,35 @@
+diff -r -U1 routino-3.0.orig/Makefile.conf routino-3.0/Makefile.conf
+--- routino-3.0.orig/Makefile.conf 2015-09-08 00:11:23.000000000 +0600
++++ routino-3.0/Makefile.conf 2016-01-04 13:02:46.557516477 +0600
+@@ -47,3 +47,3 @@
+ ifneq ($(HOST),MINGW)
+-prefix=/usr/local
++prefix=/usr
+ bindir=$(prefix)/bin
+@@ -51,3 +51,3 @@
+ libdir=$(prefix)/lib
+-docdir=$(prefix)/doc/routino
++docdir=$(prefix)/share/doc/$(PF)
+ datadir=$(prefix)/share/routino
+@@ -69,3 +69,3 @@
+ # Language dialect selection
+-CFLAGS=-std=c99
++CFLAGS+=-std=c99
+
+@@ -75,3 +75,3 @@
+ # Optimisation options
+-CFLAGS+=-O3
++#CFLAGS+=-O3
+ CFLAGS+=-ffast-math
+@@ -86,3 +86,3 @@
+ # Maths library
+-LDFLAGS=-lm
++LDFLAGS+=-lm
+
+@@ -121,4 +121,4 @@
+ # Required for xz support (uncomment these two lines if required)
+-#CFLAGS+=-DUSE_XZ
+-#LDFLAGS+=-llzma
++CFLAGS+=-DUSE_XZ
++LDFLAGS+=-llzma
+
diff --git a/sci-geosciences/routino/metadata.xml b/sci-geosciences/routino/metadata.xml
new file mode 100644
index 000000000000..577c6e944a64
--- /dev/null
+++ b/sci-geosciences/routino/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
+ An application for finding a route between two points using the dataset
+ of topographical information collected by http://www.OpenStreetMap.org.
+ This router uses a routing algorithm that takes OSM format data as its input
+ and calculates either the shortest or quickest route between two points.
+ To optimise the routing a custom database format is used.
+ This allows the routing to be performed quickly after a modest one-off pre-processing stage.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-geosciences/routino/routino-3.0_p1.ebuild b/sci-geosciences/routino/routino-3.0_p1.ebuild
new file mode 100644
index 000000000000..698b897d9b14
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.0_p1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="http://www.routino.org/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tgz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="!<sci-geosciences/qmapshack-1.5"
+PATCHES=( "${FILESDIR}"/makefile-conf.patch )
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake -j1
+}