summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/viking/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/viking/files')
-rw-r--r--sci-geosciences/viking/files/1.3-autoreconf.patch12
-rw-r--r--sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch53
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-geosciences/viking/files/1.3-autoreconf.patch b/sci-geosciences/viking/files/1.3-autoreconf.patch
new file mode 100644
index 000000000000..c8ddd6f6873a
--- /dev/null
+++ b/sci-geosciences/viking/files/1.3-autoreconf.patch
@@ -0,0 +1,12 @@
+--- configure.ac.orig 2012-05-31 09:40:33.543090992 +0200
++++ configure.ac 2012-05-31 09:40:44.372640811 +0200
+@@ -350,9 +350,6 @@
+ help/Makefile
+ doc/Makefile
+ doc/examples/Makefile])
+-if test x$enable_gtk_doc = xyes; then
+-AC_CONFIG_FILES([doc/reference/Makefile])
+-fi
+ AC_OUTPUT([
+ viking.spec
+ ])
diff --git a/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
new file mode 100644
index 000000000000..d559746ff81c
--- /dev/null
+++ b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
@@ -0,0 +1,53 @@
+commit 25043ca24a55468dc9eeaa7335a24d132c51b07d
+Author: Rob Norris <rw_norris@hotmail.com>
+Date: Mon Mar 9 23:25:15 2015 +0000
+
+ SF Bugs#117: Confirm capability with GPSD_API_MAJOR_VERSION=6 (gpsd 3.12 / libgps.so.22)
+
+diff --git a/src/vikgpslayer.c b/src/vikgpslayer.c
+index daf6d42..ca4be29 100644
+--- a/src/vikgpslayer.c
++++ b/src/vikgpslayer.c
+@@ -1673,7 +1673,7 @@ static gboolean gpsd_data_available(GIOChannel *source, GIOCondition condition,
+ if (condition == G_IO_IN) {
+ #if GPSD_API_MAJOR_VERSION == 3 || GPSD_API_MAJOR_VERSION == 4
+ if (!gps_poll(&vgl->vgpsd->gpsd)) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ if (gps_read(&vgl->vgpsd->gpsd) > -1) {
+ // Reuse old function to perform operations on the new GPS data
+ gpsd_raw_hook(vgl->vgpsd, NULL);
+@@ -1718,7 +1718,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+
+ if (gps_open_r(vgl->gpsd_host, vgl->gpsd_port, /*(struct gps_data_t *)*/vgl->vgpsd) != 0) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+ if (gps_open(vgl->gpsd_host, vgl->gpsd_port, &vgl->vgpsd->gpsd) != 0) {
+ #else
+@@ -1757,7 +1757,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ #if GPSD_API_MAJOR_VERSION == 3
+ gps_query(&vgl->vgpsd->gpsd, "w+x");
+ #endif
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
+ #endif
+
+@@ -1813,13 +1813,13 @@ static void rt_gpsd_disconnect(VikGpsLayer *vgl)
+ vgl->realtime_io_channel = NULL;
+ }
+ if (vgl->vgpsd) {
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_DISABLE, NULL);
+ #endif
+ gps_close(&vgl->vgpsd->gpsd);
+ #if GPSD_API_MAJOR_VERSION == 3
+ free(vgl->vgpsd);
+-#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ g_free(vgl->vgpsd);
+ #endif
+ vgl->vgpsd = NULL;