summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-06-09 15:38:03 +0200
committerPacho Ramos <pacho@gentoo.org>2019-06-09 15:51:15 +0200
commit24bcd360ef430a259d2f2c22bd5052f468da3e0e (patch)
tree5f96579131bfe2068aab5333b65e1a946cce3ac1 /sci-geosciences
parentx11-misc/qtfm: Add live ebuild (diff)
downloadgentoo-24bcd360ef430a259d2f2c22bd5052f468da3e0e.tar.gz
gentoo-24bcd360ef430a259d2f2c22bd5052f468da3e0e.tar.bz2
gentoo-24bcd360ef430a259d2f2c22bd5052f468da3e0e.zip
sci-geosciences/gnome-maps: Bump to 3.30.3.1
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-3.30.3.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 02845ad7b3a2..3da97278325d 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
+DIST gnome-maps-3.30.3.1.tar.xz 2175840 BLAKE2B 0c2f44ec3262715d98e1a0412ca305e15916cdb92df5fc5b04df34b65a7b9c55d4f5dd9c54f9f9dc34f8e6dd889f60d7993b59ca0cd92e4e60b22b506877b24c SHA512 02d3b1b305c1011a60a34566847962ec3c32ee3563ce2c327b810fae24c2df08354d8420f1986645d861cfef7a35f336d67d4576a3e2f61eabdd972b8d070a8e
DIST gnome-maps-3.30.3.tar.xz 2176712 BLAKE2B 8595643ddf3f6c419fdc053561e49e62d6bd6e3713d3d809d3fe73cd1aecf3361e3f6592fb53d6963cbdd5fc3edaf1dcb616059da9e5e506a3399d00a9a65de7 SHA512 f3481266c6cf792da71ef40ce489c13fdd807dab91238e02b815b25e29119ffb56212fb03078e14004cca27e24906af1b94f7f3c4325bbf4f332c782c79d8203
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.30.3.1.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.30.3.1.ebuild
new file mode 100644
index 000000000000..9aea12d14292
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-3.30.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/gjs-1.50.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}