summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2020-10-10 16:34:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-11-25 10:16:46 +0200
commit55963a3f7ff33af3182040c076132590fc9be166 (patch)
treed7aafc6511349d858e9e88ae40e0a6af00883f85 /sci-geosciences
parentwww-servers/tomcat: bump to 7.0.107 (diff)
downloadgentoo-55963a3f7ff33af3182040c076132590fc9be166.tar.gz
gentoo-55963a3f7ff33af3182040c076132590fc9be166.tar.bz2
gentoo-55963a3f7ff33af3182040c076132590fc9be166.zip
sci-geosciences/grass: fix build failure
Fix build failure during highly parallel build. Closes: https://bugs.gentoo.org/746590 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/files/grass-7.8-flock.patch17
-rw-r--r--sci-geosciences/grass/grass-7.8.3.ebuild5
2 files changed, 22 insertions, 0 deletions
diff --git a/sci-geosciences/grass/files/grass-7.8-flock.patch b/sci-geosciences/grass/files/grass-7.8-flock.patch
new file mode 100644
index 000000000000..4070f228dbb0
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-7.8-flock.patch
@@ -0,0 +1,17 @@
+diff -Naur grass-7.8.3.org/include/Make/HtmlRules.make grass-7.8.3/include/Make/HtmlRules.make
+--- grass-7.8.3.org/include/Make/HtmlRules.make 2020-05-05 10:51:50.000000000 +0200
++++ grass-7.8.3/include/Make/HtmlRules.make 2020-10-10 13:43:42.800880621 +0200
+@@ -11,10 +11,10 @@
+ endif
+
+ $(HTMLDIR)/%.png: %.png | $(HTMLDIR)
+- $(INSTALL_DATA) $< $@
++ flock $@ $(INSTALL_DATA) $< $@
+
+ $(HTMLDIR)/%.jpg: %.jpg | $(HTMLDIR)
+- $(INSTALL_DATA) $< $@
++ flock $@ $(INSTALL_DATA) $< $@
+
+ $(HTMLDIR)/%.gif: %.gif | $(HTMLDIR)
+- $(INSTALL_DATA) $< $@
++ flock $@ $(INSTALL_DATA) $< $@
diff --git a/sci-geosciences/grass/grass-7.8.3.ebuild b/sci-geosciences/grass/grass-7.8.3.ebuild
index ab8ab4cf98a1..e8911d37392c 100644
--- a/sci-geosciences/grass/grass-7.8.3.ebuild
+++ b/sci-geosciences/grass/grass-7.8.3.ebuild
@@ -79,6 +79,11 @@ BDEPEND="
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ # bug 746590
+ "${FILESDIR}/${PN}-7.8-flock.patch"
+)
+
pkg_setup() {
if use lapack; then
local mylapack=$(eselect lapack show)