summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2021-11-29 23:05:10 -1000
committerMarc Schiffbauer <mschiff@gentoo.org>2021-11-29 23:05:10 -1000
commit8321543ab1c500a4444f359423df7e8f677c5eb6 (patch)
tree7ddf515b67aa06d38f4ee37f4d0893c3a34a9eaa /sci-geosciences
parentsci-geosciences/opencpn-plugin-logbookkonni: update live version (diff)
downloadgentoo-8321543ab1c500a4444f359423df7e8f677c5eb6.tar.gz
gentoo-8321543ab1c500a4444f359423df7e8f677c5eb6.tar.bz2
gentoo-8321543ab1c500a4444f359423df7e8f677c5eb6.zip
sci-geosciences/opencpn-plugin-logbookkonni: add cmake patch
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-logbookkonni/files/cmake.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/files/cmake.patch b/sci-geosciences/opencpn-plugin-logbookkonni/files/cmake.patch
new file mode 100644
index 000000000000..4221ce9f82cd
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-logbookkonni/files/cmake.patch
@@ -0,0 +1,57 @@
+diff -urN LogbookKonni_pi-1.4.22.0.orig/cmake/PluginInstall.cmake LogbookKonni_pi-1.4.22.0/cmake/PluginInstall.cmake
+--- LogbookKonni_pi-1.4.22.0.orig/cmake/PluginInstall.cmake 2021-10-30 07:35:43.000000000 -1000
++++ LogbookKonni_pi-1.4.22.0/cmake/PluginInstall.cmake 2021-11-29 22:31:48.755156001 -1000
+@@ -6,7 +6,7 @@
+ # Installation items and layout.
+ # ~~~
+
+-include(Metadata)
++#include(Metadata)
+
+ if (APPLE)
+ install(
+diff -urN LogbookKonni_pi-1.4.22.0.orig/cmake/Targets.cmake LogbookKonni_pi-1.4.22.0/cmake/Targets.cmake
+--- LogbookKonni_pi-1.4.22.0.orig/cmake/Targets.cmake 2021-10-30 07:35:43.000000000 -1000
++++ LogbookKonni_pi-1.4.22.0/cmake/Targets.cmake 2021-11-29 22:31:48.756156018 -1000
+@@ -8,7 +8,7 @@
+ return()
+ endif ()
+
+-include(Metadata)
++#include(Metadata)
+
+ if (UNIX AND NOT APPLE AND NOT QT_ANDROID)
+ set(_LINUX ON)
+diff -urN LogbookKonni_pi-1.4.22.0.orig/CMakeLists.txt LogbookKonni_pi-1.4.22.0/CMakeLists.txt
+--- LogbookKonni_pi-1.4.22.0.orig/CMakeLists.txt 2021-10-30 07:35:43.000000000 -1000
++++ LogbookKonni_pi-1.4.22.0/CMakeLists.txt 2021-11-29 22:42:03.398496368 -1000
+@@ -27,6 +27,7 @@
+ endif ()
+ message(STATUS "Cmake version: ${CMAKE_VERSION}.")
+
++set(BUILD_TYPE "tarball")
+
+ # -------- Build setup (mostly in PluginCompiler) --------
+ #
+@@ -57,6 +58,7 @@
+
+ option(PLUGIN_USE_SVG "Use SVG graphics" ON)
+
++
+ include(PluginOptions)
+
+ #
+@@ -135,9 +137,10 @@
+ create_targets(
+ ${PROJECT_SOURCE_DIR}/flatpak/org.opencpn.OpenCPN.Plugin.logbook.yaml
+ )
+-if ("${BUILD_TYPE}" STREQUAL "")
+- return ()
+-endif ()
++#if ("${BUILD_TYPE}" STREQUAL "")
++# return ()
++#endif ()
++include(PluginLibs)
+
+ if (NOT ${BUILD_TYPE} STREQUAL "flatpak")
+ # Build package as required (flatpak already dealt with).