summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-01-31 19:13:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-01 23:40:00 +0100
commit88d063fca542cf1a5b271ee80bf97087107de261 (patch)
tree443af6ce302da8f5140eef42a64d1e67777b577d /sci-geosciences
parentsci-geosciences/osm-gps-map: remove unused patch (diff)
downloadgentoo-88d063fca542cf1a5b271ee80bf97087107de261.tar.gz
gentoo-88d063fca542cf1a5b271ee80bf97087107de261.tar.bz2
gentoo-88d063fca542cf1a5b271ee80bf97087107de261.zip
sci-geosciences/viking: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/3742
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/viking/files/1.3-autoreconf.patch12
-rw-r--r--sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch53
2 files changed, 0 insertions, 65 deletions
diff --git a/sci-geosciences/viking/files/1.3-autoreconf.patch b/sci-geosciences/viking/files/1.3-autoreconf.patch
deleted file mode 100644
index c8ddd6f6873a..000000000000
--- a/sci-geosciences/viking/files/1.3-autoreconf.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac.orig 2012-05-31 09:40:33.543090992 +0200
-+++ configure.ac 2012-05-31 09:40:44.372640811 +0200
-@@ -350,9 +350,6 @@
- help/Makefile
- doc/Makefile
- doc/examples/Makefile])
--if test x$enable_gtk_doc = xyes; then
--AC_CONFIG_FILES([doc/reference/Makefile])
--fi
- AC_OUTPUT([
- viking.spec
- ])
diff --git a/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
deleted file mode 100644
index d559746ff81c..000000000000
--- a/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-commit 25043ca24a55468dc9eeaa7335a24d132c51b07d
-Author: Rob Norris <rw_norris@hotmail.com>
-Date: Mon Mar 9 23:25:15 2015 +0000
-
- SF Bugs#117: Confirm capability with GPSD_API_MAJOR_VERSION=6 (gpsd 3.12 / libgps.so.22)
-
-diff --git a/src/vikgpslayer.c b/src/vikgpslayer.c
-index daf6d42..ca4be29 100644
---- a/src/vikgpslayer.c
-+++ b/src/vikgpslayer.c
-@@ -1673,7 +1673,7 @@ static gboolean gpsd_data_available(GIOChannel *source, GIOCondition condition,
- if (condition == G_IO_IN) {
- #if GPSD_API_MAJOR_VERSION == 3 || GPSD_API_MAJOR_VERSION == 4
- if (!gps_poll(&vgl->vgpsd->gpsd)) {
--#elif GPSD_API_MAJOR_VERSION == 5
-+#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
- if (gps_read(&vgl->vgpsd->gpsd) > -1) {
- // Reuse old function to perform operations on the new GPS data
- gpsd_raw_hook(vgl->vgpsd, NULL);
-@@ -1718,7 +1718,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
- vgl->vgpsd = g_malloc(sizeof(VglGpsd));
-
- if (gps_open_r(vgl->gpsd_host, vgl->gpsd_port, /*(struct gps_data_t *)*/vgl->vgpsd) != 0) {
--#elif GPSD_API_MAJOR_VERSION == 5
-+#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
- vgl->vgpsd = g_malloc(sizeof(VglGpsd));
- if (gps_open(vgl->gpsd_host, vgl->gpsd_port, &vgl->vgpsd->gpsd) != 0) {
- #else
-@@ -1757,7 +1757,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
- #if GPSD_API_MAJOR_VERSION == 3
- gps_query(&vgl->vgpsd->gpsd, "w+x");
- #endif
--#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
-+#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
- gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
- #endif
-
-@@ -1813,13 +1813,13 @@ static void rt_gpsd_disconnect(VikGpsLayer *vgl)
- vgl->realtime_io_channel = NULL;
- }
- if (vgl->vgpsd) {
--#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
-+#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
- gps_stream(&vgl->vgpsd->gpsd, WATCH_DISABLE, NULL);
- #endif
- gps_close(&vgl->vgpsd->gpsd);
- #if GPSD_API_MAJOR_VERSION == 3
- free(vgl->vgpsd);
--#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
-+#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
- g_free(vgl->vgpsd);
- #endif
- vgl->vgpsd = NULL;