summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-07-20 23:07:10 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-07-20 23:07:10 +0700
commitb21cfa942340c2940fd4783f4810abf772617a20 (patch)
tree08a8eb02c944acce99bb59982cff00e695dbd292 /sci-geosciences
parentdev-util/pycharm-community: bump to 2023.1.4 (diff)
downloadgentoo-b21cfa942340c2940fd4783f4810abf772617a20.tar.gz
gentoo-b21cfa942340c2940fd4783f4810abf772617a20.tar.bz2
gentoo-b21cfa942340c2940fd4783f4810abf772617a20.zip
sci-geosciences/routino: bump to 3.4.1
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/routino/Manifest1
-rw-r--r--sci-geosciences/routino/routino-3.4.1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index 4cce63994eb1..e3229b188be5 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1 +1,2 @@
DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
+DIST routino-3.4.1.tgz 2591859 BLAKE2B cdc2018cb735c190258c9f4ebf09ad14d27923fcc520b3c58fb910e63d93e280bbad345ca1c82b31284827cf914f5da45b8f5a69c9ac1721b3f056dfd9d2e918 SHA512 c9e6dea5c60a265f7a5c7217711d2c880f201d1102740d756e10f731ace785a7afd7b84cdfb8485ee3af58b5a0f1b0e8e273dab1deedd319b27c77d400b30baa
diff --git a/sci-geosciences/routino/routino-3.4.1.ebuild b/sci-geosciences/routino/routino-3.4.1.ebuild
new file mode 100644
index 000000000000..3a03984a6ad0
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.4.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig[pcre]
+ )
+"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
+
+src_prepare() {
+ default
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+}
+
+src_compile() {
+ emake -j1
+
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON} src/_router.c src/_database.cc || die
+ distutils-r1_python_compile
+}
+
+src_test() {
+ emake test
+
+ # Need to fix import issues with these
+ #if use python; then
+ # pushd python > /dev/null || die
+ # distutils-r1_src_test
+ # popd > /dev/null || die
+ #fi
+}
+
+python_test() {
+ emake PYTHON=${EPYTHON} test
+}
+
+src_install() {
+ default
+
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_src_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null || die
+ fi
+}