summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-25 16:21:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-25 16:35:22 +0100
commitb25193eca46c3cd588ff2abfa8c99a3e62d52341 (patch)
treee2af6d72ae461654e5d9a715ea3d05a23a21575b /sci-geosciences
parentgames-arcade/kobodeluxe: drop 0.5.1-r1 (diff)
downloadgentoo-b25193eca46c3cd588ff2abfa8c99a3e62d52341.tar.gz
gentoo-b25193eca46c3cd588ff2abfa8c99a3e62d52341.tar.bz2
gentoo-b25193eca46c3cd588ff2abfa8c99a3e62d52341.zip
sci-geosciences/qmapshack: Drop 1.14.0, unbuildable with Qt 5.15
Bug: https://bugs.gentoo.org/761079 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/files/FindPROJ4.cmake152
-rw-r--r--sci-geosciences/qmapshack/files/qmapshack-positioning.patch9
-rw-r--r--sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch67
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.14.0.ebuild38
5 files changed, 0 insertions, 267 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index c0b96c104ce6..3ddd56bffe95 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1,2 +1 @@
-DIST qmapshack-1.14.0.tar.gz 12541988 BLAKE2B 146df8ab42bd5a5249207b88bf1a17b4ba20706c8114cc059b847d0b32c9d53919f931d778402a10dd62f0d86948bff8eefd29684c433c1d4bfd7e2ce019ce55 SHA512 675a72a79839ad0b96fc0717ad7eca43c4ce331645ba3ad1325f9bf114abcf2ecd164eeab0c41775fe84aa626fc67272cd9c869047f57b225ff493f66881ff99
DIST qmapshack-1.15.1.tar.gz 46265787 BLAKE2B b690d1e0ac698cee6969ef3cf35dd3b6102dd292993695fed81416a2bfe396e88bd8004b03a7eeb5df30c817331b83c55452f96200bd6c45145e86eb163ca988 SHA512 c01fc75fd6466a97e82b8f9822dfada87ededcec53e62a3dc42e36463c195ad4ba16c19a4748d48b26a0e957303f2724ec88eecb5d64676c74dbdaeebfadf17a
diff --git a/sci-geosciences/qmapshack/files/FindPROJ4.cmake b/sci-geosciences/qmapshack/files/FindPROJ4.cmake
deleted file mode 100644
index 093deaa79aed..000000000000
--- a/sci-geosciences/qmapshack/files/FindPROJ4.cmake
+++ /dev/null
@@ -1,152 +0,0 @@
-#.rst:
-# FindPROJ4
-# --------
-#
-# Find the proj includes and library.
-#
-# IMPORTED Targets
-# ^^^^^^^^^^^^^^^^
-#
-# This module defines :prop_tgt:`IMPORTED` target ``PROJ4::proj``,
-# if Proj.4 has been found.
-#
-# Result Variables
-# ^^^^^^^^^^^^^^^^
-#
-# This module defines the following variables:
-#
-# ::
-#
-# PROJ4_INCLUDE_DIRS - where to find proj_api.h, etc.
-# PROJ4_LIBRARIES - List of libraries when using libproj.
-# PROJ4_FOUND - True if libproj found.
-#
-# ::
-#
-# PROJ4_VERSION - The version of libproj found (x.y.z)
-# PROJ4_VERSION_MAJOR - The major version of libproj
-# PROJ4_VERSION_MINOR - The minor version of libproj
-# PROJ4_VERSION_PATCH - The patch version of libproj
-# PROJ4_VERSION_TWEAK - always 0
-# PROJ4_VERSION_COUNT - The number of version components, always 3
-#
-# Hints
-# ^^^^^
-#
-# A user may set ``PROJ4_ROOT`` to a libproj installation root to tell this
-# module where to look exclusively.
-
-#=============================================================================
-# Copyright 2016 Kai Pastor
-#
-#
-# This file was derived from CMake 3.5's module FindZLIB.cmake
-# which has the following terms:
-#
-# Copyright 2001-2011 Kitware, Inc.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-#
-# * Redistributions in binary form must reproduce the above copyright notice,
-# this list of conditions and the following disclaimer in the documentation
-# and/or other materials provided with the distribution.
-#
-# * The names of Kitware, Inc., the Insight Consortium, or the names of
-# any consortium members, or of any contributors, may not be used to
-# endorse or promote products derived from this software without
-# specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS ``AS IS''
-# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
-# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#=============================================================================
-
-# Search PROJ4_ROOT exclusively if it is set.
-if(PROJ4_ROOT)
- set(_PROJ4_SEARCH PATHS ${PROJ4_ROOT} NO_DEFAULT_PATH)
-else()
- set(_PROJ4_SEARCH)
-endif()
-
-find_path(PROJ4_INCLUDE_DIR NAMES proj_api.h ${_PROJ4_SEARCH} PATH_SUFFIXES include)
-mark_as_advanced(PROJ4_INCLUDE_DIR)
-
-if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj_api.h")
- file(STRINGS "${PROJ4_INCLUDE_DIR}/proj_api.h" PROJ4_H REGEX "^#define PJ_VERSION [0-9]+$")
-
- string(REGEX REPLACE "^.*PJ_VERSION ([0-9]).*$" "\\1" PROJ4_VERSION_MAJOR "${PROJ4_H}")
- string(REGEX REPLACE "^.*PJ_VERSION [0-9]([0-9]).*$" "\\1" PROJ4_VERSION_MINOR "${PROJ4_H}")
- string(REGEX REPLACE "^.*PJ_VERSION [0-9][0-9]([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ4_H}")
- set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
- set(PROJ4_VERSION_COUNT 3)
-endif()
-
-# Allow PROJ4_LIBRARY to be set manually, as the location of the proj library
-if(NOT PROJ4_LIBRARY)
- set(PROJ4_NAMES proj)
- set(PROJ4_NAMES_DEBUG projd)
- if(WIN32 AND DEFINED PROJ4_VERSION_MAJOR AND DEFINED PROJ4_VERSION_MINOR)
- list(APPEND PROJ4_NAMES proj_${PROJ4_VERSION_MAJOR}_${PROJ4_VERSION_MINOR})
- list(APPEND PROJ4_NAMES projd_${PROJ4_VERSION_MAJOR}_${PROJ4_VERSION_MINOR})
- endif()
- find_library(PROJ4_LIBRARY_RELEASE NAMES ${PROJ4_NAMES} ${_PROJ4_SEARCH} PATH_SUFFIXES lib)
- find_library(PROJ4_LIBRARY_DEBUG NAMES ${PROJ4_NAMES_DEBUG} ${_PROJ4_SEARCH} PATH_SUFFIXES lib)
- include(SelectLibraryConfigurations)
- select_library_configurations(PROJ4)
-endif()
-
-# handle the QUIETLY and REQUIRED arguments and set PROJ4_FOUND to TRUE if
-# all listed variables are TRUE
-include(FindPackageHandleStandardArgs)
-find_package_handle_standard_args(PROJ4
- REQUIRED_VARS
- PROJ4_LIBRARY
- PROJ4_INCLUDE_DIR
- VERSION_VAR
- PROJ4_VERSION
-)
-
-if(PROJ4_FOUND)
- set(PROJ4_INCLUDE_DIRS ${PROJ4_INCLUDE_DIR})
-
- if(NOT PROJ4_LIBRARIES)
- set(PROJ4_LIBRARIES ${PROJ4_LIBRARY})
- endif()
-
- if(NOT TARGET PROJ4::proj)
- add_library(PROJ4::proj UNKNOWN IMPORTED)
- set_target_properties(PROJ4::proj PROPERTIES
- INTERFACE_INCLUDE_DIRECTORIES "${PROJ4_INCLUDE_DIRS}")
-
- if(PROJ4_LIBRARY_RELEASE)
- set_property(TARGET PROJ4::proj APPEND PROPERTY
- IMPORTED_CONFIGURATIONS RELEASE)
- set_target_properties(PROJ4::proj PROPERTIES
- IMPORTED_LOCATION_RELEASE "${PROJ4_LIBRARY_RELEASE}")
- endif()
-
- if(PROJ4_LIBRARY_DEBUG)
- set_property(TARGET PROJ4::proj APPEND PROPERTY
- IMPORTED_CONFIGURATIONS DEBUG)
- set_target_properties(PROJ4::proj PROPERTIES
- IMPORTED_LOCATION_DEBUG "${PROJ4_LIBRARY_DEBUG}")
- endif()
-
- if(NOT PROJ4_LIBRARY_RELEASE AND NOT PROJ4_LIBRARY_DEBUG)
- set_property(TARGET PROJ4::proj APPEND PROPERTY
- IMPORTED_LOCATION "${PROJ4_LIBRARY}")
- endif()
- endif()
-endif()
diff --git a/sci-geosciences/qmapshack/files/qmapshack-positioning.patch b/sci-geosciences/qmapshack/files/qmapshack-positioning.patch
deleted file mode 100644
index c0f13fc884e5..000000000000
--- a/sci-geosciences/qmapshack/files/qmapshack-positioning.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -U2 qmapshack-1.13.0.orig/CMakeLists.txt qmapshack-1.13.0/CMakeLists.txt
---- qmapshack-1.13.0.orig/CMakeLists.txt 2019-04-08 18:08:10.000000000 +0200
-+++ qmapshack-1.13.0/CMakeLists.txt 2019-05-06 23:19:15.330580322 +0200
-@@ -131,4 +131,5 @@
- find_package(Qt5LinguistTools REQUIRED)
- find_package(Qt5PrintSupport REQUIRED)
-+find_package(Qt5Positioning REQUIRED)
- find_package(Qt5UiTools REQUIRED)
- find_package(Qt5Network REQUIRED)
diff --git a/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch b/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch
deleted file mode 100644
index 08d8946f69d4..000000000000
--- a/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/gis/wpt/CGisItemWpt.cpp qmapshack-V_1.15.0/src/qmapshack/gis/wpt/CGisItemWpt.cpp
---- qmapshack-V_1.15.0.orig/src/qmapshack/gis/wpt/CGisItemWpt.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmapshack/gis/wpt/CGisItemWpt.cpp 2020-06-22 17:41:58.776553045 +0700
-@@ -38,6 +38,7 @@
-
- #include <QtWidgets>
- #include <QtXml>
-+#include <QPainterPath>
-
- IGisItem::key_t CGisItemWpt::keyUserFocus;
- QMap<searchProperty_e, CGisItemWpt::fSearch> CGisItemWpt::keywordLambdaMap;
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/helpers/CDraw.cpp qmapshack-V_1.15.0/src/qmapshack/helpers/CDraw.cpp
---- qmapshack-V_1.15.0.orig/src/qmapshack/helpers/CDraw.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmapshack/helpers/CDraw.cpp 2020-06-22 17:45:43.431558615 +0700
-@@ -24,6 +24,7 @@
- #include <QImage>
- #include <QPointF>
- #include <QtMath>
-+#include <QPainterPath>
-
- QPen CDraw::penBorderBlue(QColor(10, 10, 150, 220), 2);
- QPen CDraw::penBorderGray(Qt::lightGray, 2);
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/map/CMapIMG.cpp qmapshack-V_1.15.0/src/qmapshack/map/CMapIMG.cpp
---- qmapshack-V_1.15.0.orig/src/qmapshack/map/CMapIMG.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmapshack/map/CMapIMG.cpp 2020-06-22 17:47:21.413561045 +0700
-@@ -33,6 +33,7 @@
- #include "units/IUnit.h"
-
- #include <QtWidgets>
-+#include <QPainterPath>
-
- #undef DEBUG_SHOW_SECT_DESC
- #undef DEBUG_SHOW_TRE_DATA
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/mouse/IMouseSelect.cpp qmapshack-V_1.15.0/src/qmapshack/mouse/IMouseSelect.cpp
---- qmapshack-V_1.15.0.orig/src/qmapshack/mouse/IMouseSelect.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmapshack/mouse/IMouseSelect.cpp 2020-06-22 17:43:31.338555340 +0700
-@@ -23,6 +23,7 @@
- #include "mouse/IScrOpt.h"
-
- #include <QtWidgets>
-+#include <QPainterPath>
-
- IMouseSelect::IMouseSelect(CGisDraw *gis, CCanvas *canvas, CMouseAdapter *mouse)
- : IMouse(gis, canvas, mouse)
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmaptool/helpers/CDraw.cpp qmapshack-V_1.15.0/src/qmaptool/helpers/CDraw.cpp
---- qmapshack-V_1.15.0.orig/src/qmaptool/helpers/CDraw.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmaptool/helpers/CDraw.cpp 2020-06-22 17:49:14.789563856 +0700
-@@ -24,6 +24,7 @@
- #include <QImage>
- #include <QPointF>
- #include <QtMath>
-+#include <QPainterPath>
-
- QPen CDraw::penBorderBlue(QColor(10,10,150,220),2);
- QPen CDraw::penBorderGray(Qt::lightGray,2);
-diff -U3 -r qmapshack-V_1.15.0.orig/src/qmaptool/overlay/COverlayCutMap.cpp qmapshack-V_1.15.0/src/qmaptool/overlay/COverlayCutMap.cpp
---- qmapshack-V_1.15.0.orig/src/qmaptool/overlay/COverlayCutMap.cpp 2020-06-14 17:22:49.000000000 +0700
-+++ qmapshack-V_1.15.0/src/qmaptool/overlay/COverlayCutMap.cpp 2020-06-22 17:50:08.109565178 +0700
-@@ -24,6 +24,8 @@
-
- #include <functional>
- #include <QtWidgets>
-+#include <QPainterPath>
-+
- using std::bind;
-
- static inline qreal sqr(qreal a)
diff --git a/sci-geosciences/qmapshack/qmapshack-1.14.0.ebuild b/sci-geosciences/qmapshack/qmapshack-1.14.0.ebuild
deleted file mode 100644
index acb33f65883f..000000000000
--- a/sci-geosciences/qmapshack/qmapshack-1.14.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils xdg
-
-DESCRIPTION="GPS mapping utility"
-HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
-SRC_URI="https://github.com/Maproom/${PN}/archive/V_1.14.0.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="dev-qt/qtwebengine:5[widgets]
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qtprintsupport:5
- dev-qt/qtpositioning:5
- dev-qt/qtdbus:5
- dev-qt/qttest:5
- dev-qt/designer:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
- dev-libs/quazip
- >=sci-geosciences/routino-3.1.1
- sci-libs/gdal
- >=sci-libs/proj-5.0.0
- sci-libs/alglib"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
-
-PATCHES=( "${FILESDIR}"/${PN}-positioning.patch )
-S="${WORKDIR}"/${PN}-V_${PV}
-
-src_prepare() {
- cmake-utils_src_prepare
- cp "${FILESDIR}"/FindPROJ4.cmake cmake/Modules/ || die
-}