summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-08 11:01:18 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-08 11:01:26 -0400
commitc0e3ab5a829f86e167d3f5d498e1382af8359816 (patch)
treef76d991faaf475a44e8f73c2d57376799756e80a /sci-geosciences
parentgnome-base/gnome-desktop: Version bump to 42.4 (diff)
downloadgentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.tar.gz
gentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.tar.bz2
gentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.zip
sci-geosciences/geocode-glib: Version bump to 3.26.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/geocode-glib/Manifest1
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
index 882ba5a4e1a7..fbd268ef3101 100644
--- a/sci-geosciences/geocode-glib/Manifest
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -1,2 +1,3 @@
DIST geocode-glib-3.26.2.tar.xz 72956 BLAKE2B 40a32fb0ba61cd91b28e57c518dc5450ce89a16889a335d19fe722c1088a4cdb085237d1fe24d08eeac62581ac68895a7a2b432d66f46fc4e03466485cfe5060 SHA512 b3ef81fac6959f6c4725ca721125cdafbbec69233f321872e17f9035266ed7616018ef54a9082fbd0a83395d18c664144cfe3b431d63744be433f058071cd435
DIST geocode-glib-3.26.3.tar.xz 75148 BLAKE2B 8eba0cb40511a724cddcab659fe0720b0c0534d811c83f8a90d21b9153af242de2a69b2c882b3eb3008ac128d1631a2ac7692c5e000284579aade987334f6cce SHA512 42313b1da24f5256ad73bd4be366d6bacf35256acc098e4865bbff58e92c5b78f4a2537e4787c6387190f10a2be2a72bc1507f7cb436e096e772195cf30fca7c
+DIST geocode-glib-3.26.4.tar.xz 75352 BLAKE2B be783328b2372e1647c3fd6debadaf8313688fe1c993cbc1e084cd9ad8ba8fec0b142a0f579f63085684ef8fafc6e7ec6f54441a085d25d9d5f2eed31a893d1b SHA512 998c2f02a8d3d34a8b6a4b031da2e7c28df27014bcf58f3374fbc0c829fff6257c2622fd9bf331e05b85fbc761c64554fb77ce2d986e0f8b59b17aa486f9f609
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild
new file mode 100644
index 000000000000..7d4b96f4ae1a
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-installed-tests=false
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dsoup2=true
+ )
+ meson_src_configure
+}