summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-15 11:53:48 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-15 11:53:48 +0200
commitcdb09fb67044e74063938f4b8091d602da75146c (patch)
tree15dd7c796c1b17ec5befc194eed429d0cb9e02a1 /sci-geosciences
parentmedia-video/mkvtoolnix: version bump to 47.0.0 (diff)
downloadgentoo-cdb09fb67044e74063938f4b8091d602da75146c.tar.gz
gentoo-cdb09fb67044e74063938f4b8091d602da75146c.tar.bz2
gentoo-cdb09fb67044e74063938f4b8091d602da75146c.zip
sci-geosciences/liblas: Fix building against boost 1.73
Closes: https://bugs.gentoo.org/722878 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Suggested-by: Attila Tóth <atoth@atoth.sote.hu> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/liblas/files/liblas-1.8.1-boost-1.73.patch55
-rw-r--r--sci-geosciences/liblas/liblas-1.8.1-r3.ebuild1
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-geosciences/liblas/files/liblas-1.8.1-boost-1.73.patch b/sci-geosciences/liblas/files/liblas-1.8.1-boost-1.73.patch
new file mode 100644
index 000000000000..288f207737bf
--- /dev/null
+++ b/sci-geosciences/liblas/files/liblas-1.8.1-boost-1.73.patch
@@ -0,0 +1,55 @@
+diff --git a/include/liblas/detail/binary.hpp b/include/liblas/detail/binary.hpp
+index d3116a1..ab20e06 100644
+--- a/include/liblas/detail/binary.hpp
++++ b/include/liblas/detail/binary.hpp
+@@ -17,6 +17,8 @@
+ #ifndef LIBLAS_DETAIL_BINARY_HPP_INCLUDED
+ #define LIBLAS_DETAIL_BINARY_HPP_INCLUDED
+
++#include <liblas/detail/endian.hpp>
++
+ #include <cassert>
+ #include <climits>
+ #include <cstring>
+@@ -25,7 +27,6 @@
+
+ #include <boost/config.hpp>
+ #include <boost/static_assert.hpp>
+-#include <boost/detail/endian.hpp>
+ #include <boost/type_traits/is_signed.hpp>
+
+ #if CHAR_BIT != 8
+@@ -43,7 +44,7 @@ namespace detail { namespace binary {
+ struct big_endian_tag {};
+ struct little_endian_tag {};
+
+-#ifdef BOOST_BIG_ENDIAN
++#ifdef LIBLAS_BIG_ENDIAN
+ typedef big_endian_tag native_endian_tag;
+ #else
+ typedef little_endian_tag native_endian_tag;
+diff --git a/src/c_api.cpp b/src/c_api.cpp
+index a70fe74..e8be785 100644
+--- a/src/c_api.cpp
++++ b/src/c_api.cpp
+@@ -96,6 +96,7 @@ using namespace liblas;
+ #endif
+
+ #include <boost/lambda/lambda.hpp>
++#include <boost/bind.hpp>
+
+ bool IsReprojectionTransform(liblas::TransformPtr const& p)
+ {
+diff --git a/src/header.cpp b/src/header.cpp
+index 9987ce1..a5c8f7d 100644
+--- a/src/header.cpp
++++ b/src/header.cpp
+@@ -54,7 +54,7 @@
+ // boost
+ #include <boost/cstdint.hpp>
+ #include <boost/lambda/lambda.hpp>
+-
++#include <boost/bind.hpp>
+ //std
+ #include <algorithm>
+ #include <fstream>
diff --git a/sci-geosciences/liblas/liblas-1.8.1-r3.ebuild b/sci-geosciences/liblas/liblas-1.8.1-r3.ebuild
index 46930174cabd..cee50e9a5456 100644
--- a/sci-geosciences/liblas/liblas-1.8.1-r3.ebuild
+++ b/sci-geosciences/liblas/liblas-1.8.1-r3.ebuild
@@ -33,6 +33,7 @@ PATCHES=(
"${FILESDIR}"/${P}-CVE-2018-20540.patch # bug 678482
"${FILESDIR}"/${P}-CVE-2018-20540-fixup.patch # bug 698846
"${FILESDIR}"/${P}-fix-debug.patch # bug 668778
+ "${FILESDIR}"/${P}-boost-1.73.patch # bug 722878
)
src_prepare() {