summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-27 19:05:36 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-27 19:07:17 +0100
commite9dbe470a0f03bb2f633fe3ccdf9338beb345607 (patch)
tree6c9f2984d8922cb8dd1f789095ae24af97e08005 /sci-geosciences
parentsci-geosciences/opencpn-plugin-weather_routing: update live ebuild (diff)
downloadgentoo-e9dbe470a0f03bb2f633fe3ccdf9338beb345607.tar.gz
gentoo-e9dbe470a0f03bb2f633fe3ccdf9338beb345607.tar.bz2
gentoo-e9dbe470a0f03bb2f633fe3ccdf9338beb345607.zip
sci-geosciences/opencpn-plugin-weather_routing: add new version
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/Manifest b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
index ffe9792a1635..4c177f21b1ff 100644
--- a/sci-geosciences/opencpn-plugin-weather_routing/Manifest
+++ b/sci-geosciences/opencpn-plugin-weather_routing/Manifest
@@ -1 +1,2 @@
+DIST opencpn-plugin-weather_routing-1.10.1.tar.gz 845403 SHA256 1ac5f51db969f2806a54ab82d062cdef748e4f77835b2f63aba8f8633490c53f SHA512 052377bc2b962b131640ecdb2e688b97325a7935f60c68652be6bdb07486278d03d09ec2c8b4b1547e5eeab1ea7613890604c800a91f185babe5bfb5221a7337 WHIRLPOOL e3cca0cbfc967da89ecc50e716f958735169912f9e520e485c4f55a2524d91f77634e620afa87f83a971fd95f4c6795f068748a3794bd27250c6277db6faa0e2
DIST opencpn-plugin-weather_routing-1.2.tar.gz 615959 SHA256 8b86c4f86092d6fcac8138c8699cf1f093ae67016caad8960222f26659b8dcc7 SHA512 99c9df317a79e89664ca45a8e3fa02a5f2c06a731d5208260d415f6acd4506fba283d4e4758a5deff3b331546ca8893282a287b32fceebdf27f0537a6d99944b WHIRLPOOL 0018e772659482f70f132a2216f5d17fb8c56418f0e7195bfe7eb791be9964d5c829fdf95258acf7d78e41723b05e3c5bf5dd57d19703f6cbb5271a31635b76a
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild
new file mode 100644
index 000000000000..ef63f49031ff
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="weather_routing_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weather Routing Plugin for OpenCPN"
+HOMEPAGE="https://github.com/seandepagnier/weather_routing_pi/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}