summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-29 17:07:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-29 17:50:29 +0200
commitb27e51a2ccf32a7adb5f2f226abdbb94704329fc (patch)
treedc2232e3f30fc54bab16bbc4d96b33422574ecca /sci-libs/ViSP/files
parentsci-libs/ViSP: bump to 3.2.0 (diff)
downloadgentoo-b27e51a2ccf32a7adb5f2f226abdbb94704329fc.tar.gz
gentoo-b27e51a2ccf32a7adb5f2f226abdbb94704329fc.tar.bz2
gentoo-b27e51a2ccf32a7adb5f2f226abdbb94704329fc.zip
sci-libs/ViSP: Fix opencv detection
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs/ViSP/files')
-rw-r--r--sci-libs/ViSP/files/ViSP-3.2.0-ocv.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/sci-libs/ViSP/files/ViSP-3.2.0-ocv.patch b/sci-libs/ViSP/files/ViSP-3.2.0-ocv.patch
new file mode 100644
index 000000000000..56347c58f968
--- /dev/null
+++ b/sci-libs/ViSP/files/ViSP-3.2.0-ocv.patch
@@ -0,0 +1,18 @@
+Index: visp-3.2.0/CMakeLists.txt
+===================================================================
+--- visp-3.2.0.orig/CMakeLists.txt
++++ visp-3.2.0/CMakeLists.txt
+@@ -574,12 +574,7 @@ if(USE_CXX11 AND NOT USE_PTHREAD)
+ endif()
+ endif()
+ VP_OPTION(USE_XML2 XML2 "" "Include xml support" "" ON IF NOT WINRT)
+-if(CMAKE_TOOLCHAIN_FILE)
+- # Find opencv2.framework for ios and naoqi
+- VP_OPTION(USE_OPENCV "MyOpenCV" QUIET "Include OpenCV support" "OpenCV_DIR;OpenCV_FOUND;OPENCV_FOUND" ON)
+-else()
+- VP_OPTION(USE_OPENCV "OpenCV;MyOpenCV" QUIET "Include OpenCV support" "OpenCV_DIR;OpenCV_FOUND;OPENCV_FOUND" ON)
+-endif()
++VP_OPTION(USE_OPENCV "OpenCV;MyOpenCV" QUIET "Include OpenCV support" "OpenCV_DIR;OpenCV_FOUND;OPENCV_FOUND" ON)
+ VP_OPTION(USE_ZLIB "ZLIB;MyZLIB" "" "Include zlib support" "" ON IF NOT WINRT AND NOT IOS)
+ VP_OPTION(USE_X11 X11 "" "Include X11 support" "" ON IF NOT WINRT AND NOT IOS)
+ # The native FindGTK2.cmake doesn't consider libgobject-2.0 that is