summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 20:26:46 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 20:27:03 +0200
commit70d893e1b7afd6b1bfaea04de24f8a322864f798 (patch)
tree153be1ea08c0fb8ca70b07d6d6e20c5302b2592f /sci-libs/alglib/alglib-3.10.0-r1.ebuild
parentapp-office/texstudio: Drop old (diff)
downloadgentoo-70d893e1b7afd6b1bfaea04de24f8a322864f798.tar.gz
gentoo-70d893e1b7afd6b1bfaea04de24f8a322864f798.tar.bz2
gentoo-70d893e1b7afd6b1bfaea04de24f8a322864f798.zip
sci-libs/alglib: Set subslot
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561460 Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/alglib/alglib-3.10.0-r1.ebuild')
-rw-r--r--sci-libs/alglib/alglib-3.10.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/alglib/alglib-3.10.0-r1.ebuild b/sci-libs/alglib/alglib-3.10.0-r1.ebuild
new file mode 100644
index 000000000000..e3a51626618c
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.10.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="http://www.alglib.net/"
+SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.gpl.tgz"
+
+SLOT="0/3.8"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+S="${WORKDIR}"/cpp/
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-3.8.2 CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_build test) )
+ cmake-utils_src_configure
+}