summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-06-26 02:41:35 +0000
committerBenda Xu <heroxbd@gentoo.org>2019-06-26 14:06:10 +0800
commit914aebf44db94fad75de5781a770ffdc97cd38a3 (patch)
tree8f07567d8477072e985305f3ede3fb4ad7937bb8 /sci-libs/blis/blis-0.5.2.ebuild
parentsci-libs/lapack: add eselect-ldso USE flag. (diff)
downloadgentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.tar.gz
gentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.tar.bz2
gentoo-914aebf44db94fad75de5781a770ffdc97cd38a3.zip
sci-libs/blis: new BLIS package as an BLAS/CBLAS alternative.
Closes: https://github.com/gentoo/gentoo/pull/12322 Signed-off-by: Mo Zhou <cdluminate@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/blis/blis-0.5.2.ebuild')
-rw-r--r--sci-libs/blis/blis-0.5.2.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/sci-libs/blis/blis-0.5.2.ebuild b/sci-libs/blis/blis-0.5.2.ebuild
new file mode 100644
index 000000000000..939d0b608d65
--- /dev/null
+++ b/sci-libs/blis/blis-0.5.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="BLAS-like Library Instantiation Software Framework"
+HOMEPAGE="https://github.com/flame/blis"
+SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="openmp pthread serial static-libs eselect-ldso doc 64bit-index"
+REQUIRED_USE="?? ( openmp pthread serial ) ?? ( eselect-ldso 64bit-index )"
+
+RDEPEND="eselect-ldso? ( !app-eselect/eselect-cblas
+ >=app-eselect/eselect-blas-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-lang/python
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-rpath.patch"
+ "${FILESDIR}/${P}-blas-provider.patch"
+ "${FILESDIR}/${P}-gh313.patch"
+)
+
+src_configure () {
+ local BLIS_FLAGS=()
+ local confname
+ # determine flags
+ if use openmp; then
+ BLIS_FLAGS+=( -t openmp )
+ elif use pthread; then
+ BLIS_FLAGS+=( -t pthreads )
+ else
+ BLIS_FLAGS+=( -t no )
+ fi
+ use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
+ # determine config name
+ case "${ARCH}" in
+ "x86" | "amd64")
+ confname=auto ;;
+ "ppc64")
+ confname=generic ;;
+ *)
+ confname=generic ;;
+ esac
+ # This is not an autotools configure file. We don't use econf here.
+ ./configure \
+ --enable-verbose-make \
+ --prefix="${BROOT}"/usr \
+ --libdir="${BROOT}"/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ --enable-blas \
+ --enable-cblas \
+ ${BLIS_FLAGS[@]} \
+ --enable-shared \
+ $confname || die
+}
+
+src_compile() {
+ DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
+ LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
+ default
+}
+
+src_test () {
+ emake check
+}
+
+src_install () {
+ default
+ use doc && dodoc README.md docs/*.md
+
+ if use eselect-ldso; then
+ dodir /usr/$(get_libdir)/blas/blis
+ insinto /usr/$(get_libdir)/blas/blis
+ doins lib/*/lib{c,}blas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+
+ local libdir=$(get_libdir) me="blis"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir})
+ if [[ ${current_blas} == blis || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ use eselect-ldso && eselect blas validate
+}