summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-03-09 19:18:06 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-03-09 19:18:21 +0100
commita5f424f0fed9c35acaa36bb112c751e839bf320e (patch)
tree15fd25777d98789c6458e4a25b7c66c7de78e306 /sci-libs/branca/branca-0.7.1.ebuild
parentnet-firewall/ipset: Fix bash-completion script (diff)
downloadgentoo-a5f424f0fed9c35acaa36bb112c751e839bf320e.tar.gz
gentoo-a5f424f0fed9c35acaa36bb112c751e839bf320e.tar.bz2
gentoo-a5f424f0fed9c35acaa36bb112c751e839bf320e.zip
sci-libs/branca: add 0.7.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/branca/branca-0.7.1.ebuild')
-rw-r--r--sci-libs/branca/branca-0.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/branca/branca-0.7.1.ebuild b/sci-libs/branca/branca-0.7.1.ebuild
new file mode 100644
index 000000000000..530dc31506f2
--- /dev/null
+++ b/sci-libs/branca/branca-0.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.0-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs/source \
+ dev-python/nbsphinx
+
+python_test() {
+ epytest -m 'not headless'
+}